4x4 light problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-16-2014, 07:56 PM
Thread Starter
  #1
Jeeper
 
Join Date: Feb 2014
Location: Boston, MA
Posts: 24
4x4 light problem

I have a 2001 wrangler sport. When I put it in 4 wheel drive, the indicator light on the dash does not light up. It does not work for either hi or lo. The actual 4 wheel drive works, just the light does not light up. In other words, the jeep shifts into 4 wheel drive, but the 4x4 light on the dash does not illuminate. Any idea how to fix this?

pdfisherman is offline   Quote
Old 02-16-2014, 07:57 PM   #2
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 48,452
The switch is inside the transfer case, its connector sticks out of the top of the transfer case on the passenger side. See if its connector is still connected.

__________________
When you have a choice, buy American.
Jerry Bransford is offline   Quote
Old 02-17-2014, 01:37 PM   #3
Jeeper
 
Join Date: Nov 2012
Posts: 114
X2 on Jerry said , if it's connected disconnect it and jump the 2 terminals on the plug and it will light if the switch on the case is bad. I have done few of these and that switch used to be 4$ at oriellys and now it's 30$!!!!!
robert0069 is offline   Quote
Sponsored Links
Advertisement
 
Old 02-18-2014, 12:28 AM   #4
Jeeper
 
NH-JK's Avatar
 
Join Date: Oct 2013
Location: New Hampshire
Posts: 534
I just swapped my switch out. It was bad, lights up as it should now. Takes about 5 minutes. Costs about $30.00
NH-JK is offline   Quote
Old 02-18-2014, 09:17 AM
Thread Starter
  #5
Jeeper
 
Join Date: Feb 2014
Location: Boston, MA
Posts: 24
Alright thanks. I'll check when I get home.
pdfisherman is offline   Quote
Old 02-18-2014, 08:43 PM   #6
Jeeper
 
NH-JK's Avatar
 
Join Date: Oct 2013
Location: New Hampshire
Posts: 534
Ironically mine just went out again! I'll have to check the wires later. I'm sure it's still under warrantee!

NH-JK is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 02:48 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.