98 TJ electrical problems - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-09-2017, 09:10 AM
Thread Starter
  #1
Jeeper
 
Join Date: Aug 2009
Posts: 49
98 TJ electrical problems

I was driving my 98 with a 4.0 5 speed yesterday.when I started having some curious electrical problems. The speedo and tach both would work intermittently but all other changes including the mileage are still working fine. Also my airbag light comes on and goes out too. Now I did have the entire dash out this fall to do the heater core, it seems to me that there is a bad connection somewhere. Also my dome light wasn't working when I opened the doors but comes on with the light switch, I replaced both door switches and it didn't help. Thanks in advance for any help you can give.

wijeepguy716 is offline   Quote
Old 01-14-2017, 02:23 PM   #2
Jeeper
 
installer's Avatar
 
Join Date: Aug 2015
Posts: 144
I had this problem a while back.
Ended up being poor connections.
Pull the instrument panel and remove the connectors then clean all and reinstall.
Worked well for me.
Seems like there are other post on here about that.
Good luck !

installer is offline   Quote
Old 01-14-2017, 03:12 PM   #3
Jeeper
 
installer's Avatar
 
Join Date: Aug 2015
Posts: 144
Found my earlier post where I fixed it :


https://www.wranglerforum.com/f282/da...s-1580546.html
installer is offline   Quote
Sponsored Links
Advertisement
 
Old 01-15-2017, 09:01 AM   #4
Jeeper
 
Join Date: Apr 2013
Posts: 13,019
Sounds like cluster is loosing CCD bus signal

It does not need the bus signal to display odometer as a cluster power on a work bench will display miles

Do the cluster self check then check the connections for the CCD twisted pair to cluster


Sent from my iPod touch using Tapatalk
Digger84 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 02:10 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.