99 TJ 2.5l start and runs @2k rpms?? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-21-2014, 04:20 AM
Thread Starter
  #1
Newb
 
Join Date: Jun 2014
Posts: 7
99 TJ 2.5l start and runs @2k rpms??

After changing out a manifold gasket cause the old one was blown...put everything back together went to start it up and it jumped straight to 2k rpms and never moved after running for no more than 2 minutes looked under the car and I have some radiator fluid that was dripping which it never has before and the jeep seemed to be running really hot...I squeezed the radiator hose and it seems to be stopped up...I don't know how I change out a exhaust manifold gasket n get this problem...any ideas anybody??

AntTim1204 is offline   Quote
Old 06-21-2014, 06:45 AM   #2
Jeeper
 
wwch99tj's Avatar
 
Join Date: Mar 2011
Location: Felton Delaware
Posts: 5,291
You need to make sure the intake is seated all the way, there are 2 dowel pins in the head that positions the intake... also make sure all of the vacuum line are attached

The antifreeze is it leaking from the radiator or the pump?
Was the temp gauge reading over 210?

wwch99tj is offline   Quote
Old 06-21-2014, 01:40 PM
Thread Starter
  #3
Newb
 
Join Date: Jun 2014
Posts: 7
Quote:
Originally Posted by wwch99tj View Post
You need to make sure the intake is seated all the way, there are 2 dowel pins in the head that positions the intake... also make sure all of the vacuum line are attached

The antifreeze is it leaking from the radiator or the pump?
Was the temp gauge reading over 210?
It's leaking from the top of the radiator...I didn't run it Lon enough to hear up that much but it was heating up quick
AntTim1204 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 12:45 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.