A/C vent control knob skips settings - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-24-2016, 05:25 AM
Thread Starter
  #1
Jeeper
 
Join Date: Apr 2013
Posts: 152
A/C vent control knob skips settings

My A/C vent knob (the one that selects dash, feet, defrost, etc.) Skips settings, and only will blow on the defrost setting right now. However, the indication on the knob is the dash vents to blow at your face when it is blowing on the defroster. In my head it seems like I just need to replace the knob, but wanted to see if anyone has had experience with this or if there could be a different problem?
I work nights and don't have time during the week to tear it apart, and I don't know that I can find the part on the weekend. I'd like to try and get the correct part in advance if possible, thanks!

evil_lies is offline   Quote
Old 03-24-2016, 07:20 AM   #2
Jeep Flip-Ur-Top Commercial Member

5-Year WF Supporting Member
 
Markrak's Avatar
 
Join Date: Jul 2010
Location: Gloucester, VA
Posts: 873
If you have the OEM plastic knobs they are famous for having the stem crack, and the knob wile no longer grip the selector shaft on the dash unit....the knob will just spin and you'll think your making a selection.

Pull the knob off and inspect it to see if that's the case. This happened to basically all of my knobs, and even had to replace some twice. Finally I found some reasonably priced billet aluminum replacements on Amazon a few years back and haven't had the problem since.

Good luck!

__________________
Turn your OEM Soft Top into a Sunrider!
Jeep Flip-Ur-Top: http://www.flipurtop.com/
Please send a PM or visit the website!
2000 Yellow TJ Sport, 5 Speed, 4.0, 31's With 1.75"BB, Flip-Ur-Top Sunrider, SpiderWeb Shade, Mostly Stock
2004 Silver Grand Cherokee Columbia Edition
1989 Black YJ 4.2L, 33's With 4" Lift...May She Rest in Peace
Markrak is offline   Quote
Old 03-24-2016, 09:25 AM   #3
Jeeper
 
gillbrak's Avatar
 
Join Date: Feb 2016
Location: Lakewood, CO
Posts: 276
Quote:
Originally Posted by Markrak View Post
If you have the OEM plastic knobs they are famous for having the stem crack, and the knob wile no longer grip the selector shaft on the dash unit....the knob will just spin and you'll think your making a selection.

Pull the knob off and inspect it to see if that's the case. This happened to basically all of my knobs, and even had to replace some twice. Finally I found some reasonably priced billet aluminum replacements on Amazon a few years back and haven't had the problem since.

Good luck!
I have similar issue. Do the knobs pull right off?
__________________
06 LJR Boosted 4.0
gillbrak is offline   Quote
Sponsored Links
Advertisement
 
Old 03-24-2016, 10:19 AM   #4
Jeeper
 
pvansch1's Avatar
 
Join Date: Sep 2014
Location: Canton
Posts: 1,389
Yes they pull off, if cracked they should come off fairly easy.
Pull off, turn the stud with a pair of pliers to verify the selector is working properly.
NAPA sells replacements for a few bucks
__________________
2002 Wrangler X
pvansch1 is online now   Quote
Old 03-24-2016, 11:31 AM   #5
Jeep Flip-Ur-Top Commercial Member

5-Year WF Supporting Member
 
Markrak's Avatar
 
Join Date: Jul 2010
Location: Gloucester, VA
Posts: 873
Quote:
Originally Posted by pvansch1 View Post
Yes they pull off, if cracked they should come off fairly easy.
Pull off, turn the stud with a pair of pliers to verify the selector is working properly.
NAPA sells replacements for a few bucks
I replaced the ones that NAPA sells twice, as they are the same quality as the OEM's and will eventually fail. I finally spent a little extra in 2011 and got these: http://www.amazon.com/Rugged-Ridge-1...ilpage_o00_s00 and haven't had an issue since.

Good luck!
__________________
Turn your OEM Soft Top into a Sunrider!
Jeep Flip-Ur-Top: http://www.flipurtop.com/
Please send a PM or visit the website!
2000 Yellow TJ Sport, 5 Speed, 4.0, 31's With 1.75"BB, Flip-Ur-Top Sunrider, SpiderWeb Shade, Mostly Stock
2004 Silver Grand Cherokee Columbia Edition
1989 Black YJ 4.2L, 33's With 4" Lift...May She Rest in Peace
Markrak is offline   Quote
Old 03-24-2016, 12:58 PM   #6
Jeeper
 
RUBI 4 MY MRS's Avatar
 
Join Date: Feb 2011
Location: Trails of Nevada
Posts: 3,333
If the knob is not bad & turning the shaft does not switch from defrost you probably have a vacuum leak. When that happens it defaults to defrost. Here are 2 links that may help.


ac/heat vent - JeepForum.com

https://www.wranglerforum.com/f210/ve...ng-117541.html
__________________


'05 Rubi TJ Unlimited
'93 Toyota 4Runner
RUBI 4 MY MRS is online now   Quote
Old 03-24-2016, 02:05 PM   #7
Jeeper
 
Join Date: Jul 2014
Posts: 55
If your only getting air out of the defrost vents you have a vacum leak. Trace the vacum line that comes off the firewall and into the intake manifold. Il bet you the little rubber elbow at the intake manifold has come completely off and is causing the issue. Or there may be a break in the line somewhere
Paul8ex is offline   Quote
Old 03-25-2016, 05:34 AM
Thread Starter
  #8
Jeeper
 
Join Date: Apr 2013
Posts: 152
Thanks for the tips guys! Hopefully I'll have a few minutes to check out the vacuum line before I go to work tomorrow. Will a leak cause the defroster position to change on the knob though? I did give the knob a few decent pulls on my way home tonight and it seems firmly in place, so I'm thinking the vacuum line sounds like a likely problem.
evil_lies is offline   Quote
Old 03-25-2016, 07:48 AM   #9
Jeeper
 
Join Date: Jul 2014
Posts: 55
if there is a vacuum leak the system will only blow air from the defrost vents no matter where you turn that knob. check the line like I said im betting it has come completely off where it connects to your intake manifold

Paul8ex is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 01:28 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.