Cruise Control Problems - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-27-2016, 07:25 PM
Thread Starter
  #1
Newb
 
Join Date: May 2013
Location: San Diego, Ca.
Posts: 11
Cruise Control Problems

I'm having trouble with my Cruise Control in my 2002 Jeep Wrangler Sahara. When I turn it on, the light on the dashboard lights up. When I try to set the speed, it works for about 10-20 seconds, and then the cruise control light goes out, and I cannot get it to come back on until I turn off the ignition switch. I'm trying to determine what part I need to replace to eliminate this problem. Anyone have a similar problem, what did you do to fix it. [email protected]


Riflmn3006 is offline   Quote
Old 03-27-2016, 07:32 PM   #2
Jeeper
 
jeepfever84's Avatar
 
Join Date: Dec 2011
Location: moses lake,wa
Posts: 84
The cruise control is controlled by a vacuum diaphragm.its sounds like you have a leak either in the diaphragm or in the vacuum line from the intake.you can test the diaphragm if you have a vacuum pump like one used for self bleeding brakes besides that just look closely at the vacuum line for any signs of a crack or chafing.since it does work for twenty seconds or so def. sounds like a vacuum leak.hope this helps

jeepfever84 is offline   Quote
Old 03-27-2016, 07:36 PM   #3
Jeeper
 
jeepfever84's Avatar
 
Join Date: Dec 2011
Location: moses lake,wa
Posts: 84
The part will look like this and is on the driver side fender
Attached Thumbnails
Click image for larger version

Name:	image-4088388744.jpg
Views:	92
Size:	75.7 KB
ID:	2920737  
jeepfever84 is offline   Quote
Sponsored Links
Advertisement
 
Old 03-27-2016, 09:49 PM   #4
Jeeper
 
Join Date: Feb 2014
Location: South Carolina
Posts: 105
I'll give you my thoughts to test it, but since you can turn off the car and when you turn it on, it might be int he cruise control activation as postulated.

But, try this...your horn working? If not, the clock spring might be at fault. It governs the horn and cruise among other things. My cruise started to work intermittently. Replaced clock spring, fixed it. Just a thought.
vertrx7 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 02:10 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.