Electrical Issue - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-16-2010, 08:19 PM
Thread Starter
  #1
Newb
 
Join Date: Mar 2010
Posts: 2
Electrical Issue

Drove the wife's 04 wrangler to work this morning, no issue.

This afternoon, it wouldn't start. First of all, dashboard showed signs of life when key was turned. Clicking from under the hood, but engine did not turn over.

Second attempt, same result for the engine, but all the dashboard instruments went crazy, swinging full range back and forth.

Third attempt, instruments swing back and forth with a consistent frequency of 1 second.

Fourth and later attempts got same result as attempt #2. With ignition key removed, between attempts, pressing brake pedal caused speedo and rev counter dials to jump full range.

Less 'life' as the attempts continued. I don't have a multimeter, so don't know for sure whether the battery is dead/dying, though I did clean the battery terminals as suggested on another forum, with no change.

My guess is a short somewhere. Any guidance/detail you can add though, much appreciated. Thank you.

tedainsworth is offline   Quote
Old 03-16-2010, 08:32 PM   #2
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 48,591
That sounds pretty much like your battery is toast. Take it out & have it load tested at your local auto parts store.
__________________
When you have a choice, buy American.
Jerry Bransford is online now   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical issue that keeps getting worse... fourtyoneantz TJ Tech Forum 2 06-28-2010 08:31 PM
Yet another electrical issue? catoct TJ Tech Forum 4 11-08-2009 12:12 PM
Electrical Issue, Need guidance asap NjTJ TJ Tech Forum 6 10-03-2009 07:36 PM
Electrical issue with my Jeep-grounding, where to start vijay YJ Tech Forum 23 08-01-2009 08:04 AM
Electrical issue macleay YJ Tech Forum 1 02-09-2008 01:40 AM





All times are GMT -5. The time now is 12:51 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.