Electrical issues - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-08-2009, 08:18 PM
Thread Starter
  #1
 
Join Date: Oct 2009
Posts: 1
Electrical issues

Alright so I recently just came back home from AIT for the military(6 months), i left my jeep in my fathers hands and i guess he never touched it? yeah bad, anyways for some reason im having issues with the directionals, hazards, custom flood lights, and the horn. The directionals barely work, the hazards never work, the custom flood lights barely work and the horn never works. Ive checked out all the fuses and nothing is wrong with them, the flasher i changed out just in case, and for some reason the directional noise(clicking) is always on no matter what? any suggestions?

bean89032 is offline   Quote
Old 10-08-2009, 10:05 PM   #2
Jeeper
 
jerryj's Avatar
 
Join Date: May 2009
Location: Idyllwild
Posts: 670
Maby it turned into a little mousy hotel ,chewed wires maby ??

jerryj is offline   Quote
Old 10-08-2009, 10:54 PM   #3
Jeeper
 
csamn2007's Avatar
 
Join Date: Aug 2009
Location: Peterson AFB CO
Posts: 1,911
Send a message via AIM to csamn2007
If it was sitting, i would have to agree with jerry.
__________________
2000 Wrangler Sport
2 in Procomp SL 1 in BL
33 in Procomp MTs
csamn2007 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
electrical issues??? elizabeth YJ Tech Forum 1 08-08-2009 05:47 PM
Some electrical issues that are driving me bonkers wrangle4me YJ Tech Forum 14 06-15-2009 03:11 PM
Electrical Issues wreckchick YJ Tech Forum 5 04-20-2009 09:51 PM
2000 jeep wrangler electrical issues ankyle62 TJ Tech Forum 1 08-28-2005 07:42 PM





All times are GMT -5. The time now is 03:07 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.