Electrical Problems - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-01-2010, 10:04 PM
Thread Starter
  #1
Jeeper
 
AKWrangler's Avatar
 
Join Date: Oct 2008
Location: Alaska
Posts: 83
Electrical Problems

My 97 has been acting really wierd lately. First Half of my Dash lights are out, that happened a couple of months ago, then about two weeks ago, I brain farted and forgot to put my oil cap back on after adding a quart of oil, then I decided to clean the engine off of the excess oil that had spewed every where and the Engine light came on, I figured something just got wet and it went off after a couple of days.

Well now the fuel switch accelerator(I think that is what it is called) starts acting up, at first I thought it might be dirty fuel injectors, so I put in a can of Sea Foam and some premium, I can tell now it's not the injectors, I tried to check the codes on the Dash but it's not working at all, so I reset the Engine check light and took her out for a test drive to see if it cleared up.

I put it in Second and she starts to bog out just like it would be if the injectors were clogged, and the Engine light comes back on, Okay now this is getting annoying. I keep on going and now it works okay, bogs a little on the up hills but no loss of power and the low rpms don't bog out any more.

I get back and my right head light blew out! well what the heck, so I go get a new headlight and got a new fuse container for my driving lights because I had notice it had blew too. so I get back and I am putting in the headlight and replacing the fuse container and I notice just under the computer (where all of the wiring is coming from), the battery handle with the sharp ends has dug into the wiring harness. Just Freakin great! I pulled back the handle out of the harness and notice quite a bit of wear and tear on the insulation, so I rewrapped it back in elecrical tape, Next weekend I am going to tear into the harness and see if there are any broken wires, or any wiring contacting another wire, I know this has to be it. At least I hope it is. I wish I could do it now but have to get back to work for now.

AKWrangler is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Preventing Possible Electrical Problems Atthehop TJ Tech Forum 6 03-01-2010 06:26 AM
'98 TJ 4.0L electrical problems and more leland TJ Tech Forum 0 12-01-2009 11:08 AM
CJ-5 electrical problems The Ole Fart CJ Tech Forum 3 09-07-2009 09:55 PM
1990 jeep wrangler 2.5 electrical problems. thecrew2999 YJ Tech Forum 3 07-25-2009 07:35 PM
electrical problems 97 tj bjsr1000 TJ Tech Forum 0 05-28-2009 06:53 PM





All times are GMT -5. The time now is 04:07 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.