Engine shutting off? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-11-2010, 01:08 PM
Thread Starter
  #1
Newb
 
Wranglerfan's Avatar
 
Join Date: Nov 2009
Location: Huntingdon, PA
Posts: 13
Engine shutting off?

I just bought my 1999 Wrangler 6 cyl. about two months ago. It runs great and has no problems but every now and then I will be sitting at a drive-thru or a red light and the engine will just shut off abruptly. When it does this the check engine light comes on but then goes out when I restart it and it runs like a champ after that. I am confused by this because it has only happened a few times so I do not know if it is a problem or not. Has anyone else experienced anything like this?

Wranglerfan is offline   Quote
Old 03-12-2010, 12:13 AM
Thread Starter
  #2
Newb
 
Wranglerfan's Avatar
 
Join Date: Nov 2009
Location: Huntingdon, PA
Posts: 13
Hasn't anyone had this happen? I was hoping that someone would know something about this.

Wranglerfan is offline   Quote
Old 03-12-2010, 12:40 AM   #3
Jeeper
 
Indy's Avatar
 
Join Date: Jun 2009
Location: Bay Area, CA
Posts: 584
Could be your TPS ... mine had same symptoms (engine RPMs will drop real low but didn't kill the engine) and I replaced the TPS and its been running fine perfectly now from last 2 months!

But before getting to TPS .. make sure your spark plugs, cap, rotor and wires are all in good condition.
Indy is offline   Quote
Sponsored Links
Advertisement
 
Old 03-12-2010, 06:15 AM   #4
MOz
Jeeper
 
MOz's Avatar
 
Join Date: Apr 2007
Location: Poconos
Posts: 2,483
Any codes?

It does sound like a either a TPS or the IAC valve. Clean the IAC using some carb/injection cleaner.
__________________


It ain't no fun unless you get some of it on you.
MOz is offline   Quote
Old 03-12-2010, 10:08 AM   #5
Jeeper
 
Join Date: Aug 2008
Posts: 2,473
If you got a check engine light - and it wasn't because you still had the key on with engine off - there may be a code stored that could give a clue.
Check that before throwing parts at it.
__________________
It's no wonder the country is falling apart - stupidity abounds!
rrich is offline   Quote
Old 03-14-2010, 03:34 PM
Thread Starter
  #6
Newb
 
Wranglerfan's Avatar
 
Join Date: Nov 2009
Location: Huntingdon, PA
Posts: 13
Well it did not show any codes but I took your advice and cleaned the IAC and it is definitely idling better than it ever has since I bought it. It also hasn't shut off on me in two days so I am hoping that the problem has been fixed. Thanks for all of the help guys I appreciate it .
Wranglerfan is offline   Quote
Old 03-14-2010, 03:39 PM   #7
MOz
Jeeper
 
MOz's Avatar
 
Join Date: Apr 2007
Location: Poconos
Posts: 2,483
Quote:
Originally Posted by Wranglerfan View Post
Well it did not show any codes but I took your advice and cleaned the IAC and it is definitely idling better than it ever has since I bought it. It also hasn't shut off on me in two days so I am hoping that the problem has been fixed. Thanks for all of the help guys I appreciate it .
The IAC is notorious for fouling. I clean this out at least once a year. You really need to take it apart to throughly clean it.

Good luck.

__________________


It ain't no fun unless you get some of it on you.
MOz is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rebuilding your engine?? Get Stroked!!! jeeper95yj YJ General Discussion Forum 6 01-01-2014 05:47 PM
Engine knock and rough idle help rumpleskins TJ Tech Forum 5 12-26-2010 04:54 PM
05 blown engine tinworm TJ General Discussion Forum 10 10-27-2009 11:58 AM
New to forum, engine install time deaglementor YJ Tech Forum 7 05-08-2009 12:14 AM
Spedo dies and the engine dies when I brake jbhouse2k TJ Tech Forum 4 03-06-2007 08:17 PM





All times are GMT -5. The time now is 03:17 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.