Glitch? or is something really wrong? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-10-2010, 06:34 AM
Thread Starter
  #1
Jeeper
 
greene91's Avatar
 
Join Date: Oct 2007
Location: Parrish, FL
Posts: 156
Glitch? or is something really wrong?

I have noticed recently that if I drive a distance of 60+ miles or so that my 4WD indicator light comes on, and it wont shut off until I stop for a while. Is it coming on because my transmission/differentials are getting too warm? Is this just a glitch? Should I be concerned if I have to drive my Jeep for a long distance?

Has anyone seen this problem on their Jeep?

Thanks

__________________
GO STEELERS!!

'99 TJ Sport, 4.0L
greene91 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 01:05 PM
Wrong manual transmission fluid listed in computer scotiez TJ Tech Forum 6 11-03-2012 10:03 PM
can someone tell me how this is wrong? (CB ant. mount) drummerwookie Communications and Electronics 3 11-18-2010 11:15 PM
TJ Error codes khenderson TJ Tech Forum 3 08-19-2005 01:36 AM





All times are GMT -5. The time now is 12:13 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.