Heater/AC Vacuum Switch plus - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Like Tree1Likes
  • 1 Post By RUBI 4 MY MRS
Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-01-2019, 02:59 PM
Thread Starter
  #1
Jeeper
 
Jeep225's Avatar
 
Join Date: Aug 2017
Location: South Jersey
Posts: 302
Heater/AC Vacuum Switch plus

Strange problem with my Heater/AC Vacuum Switch.

It was pretty much sticking on a certain settings (Dash vent) where the air/heat only came out of that setting, but if I played with the switch I was able to get it to another setting. But even sometimes it would still blow when I turned it completely off.

I installed a new switch but still having the same problem and now some of the lights aren't coming on with all 3 buttons (fan, cold/heat and heater vacuum switch.

So...

1) Could if be something else besides the Heater/ac vacuum switch that could be causing the settings to not properly work?

2) What could have caused some lights to not come on and are they individual bulbs? When replacing the heater/ac switch I only pulled that switch off of the back panel with the plug to the right of it).

Thanks

Jeep225 is offline   Quote
Old 05-08-2019, 10:11 AM
Thread Starter
  #2
Jeeper
 
Jeep225's Avatar
 
Join Date: Aug 2017
Location: South Jersey
Posts: 302
ok, let me try again for one problem.

What type of bulbs are there behind the 3 knobs (fan speed, heat/cool, and fan direction)?

Thanks
Attached Thumbnails
Click image for larger version

Name:	IMG_20190508_110733_resized_20190508_110801695.jpg
Views:	1
Size:	220.6 KB
ID:	4148415  

Jeep225 is offline   Quote
Old 05-08-2019, 09:04 PM   #3
Jeeper
 
RUBI 4 MY MRS's Avatar
 
Join Date: Feb 2011
Location: Trails of Nevada
Posts: 3,142
You need good vacuum to get it to direct airflow when switching settings. When you have low or no vacuum at the switch it will default to defrost. It does not sound like that is what is happening to you so I assume the vacuum is good.

When you turn the knob can you feel the detents clicking to the next position? If not the knob may be bad & turning freely on the shaft which is known to happen (plastic knobs). Pull the knob & inspect it & also try turning the shaft with pliers to see if the switch changes the airflow positions.

As for the lights, I’m pretty sure there are 2 bulbs in the panel & have read they are common bulbs available at most auto supply stores. I do not remember the bulb # but just remove one & take it to the store & match it, assuming one or both are bad. You should first check if the orange wire to the panel has 12v when the lights are turned on (cluster & other switches are lit).
__________________


'05 Rubi TJ Unlimited
'93 Toyota 4Runner
RUBI 4 MY MRS is offline   Quote
Sponsored Links
Advertisement
 
Old 05-16-2019, 09:12 AM
Thread Starter
  #4
Jeeper
 
Jeep225's Avatar
 
Join Date: Aug 2017
Location: South Jersey
Posts: 302
Here's a pic of one of the 3 bulbs behind the switches.

Is this strictly a dealership item or does anyone know where else I can buy these?

Thanks
Attached Thumbnails
Click image for larger version

Name:	IMG_20190516_100705_resized_20190516_100731644.jpg
Views:	5
Size:	135.7 KB
ID:	4150567  
Jeep225 is offline   Quote
Old 05-16-2019, 10:56 AM
Thread Starter
  #5
Jeeper
 
Jeep225's Avatar
 
Join Date: Aug 2017
Location: South Jersey
Posts: 302
Found the info right here...sweet.

https://www.wranglerforum.com/f282/l...ols-42785.html
Jeep225 is offline   Quote
Old 05-16-2019, 11:09 AM   #6
Jeeper
 
RUBI 4 MY MRS's Avatar
 
Join Date: Feb 2011
Location: Trails of Nevada
Posts: 3,142
That is the socket with bulb. You should be able to remove the bulb by pulling to straight out from the socket.


Then take it to the parts store & they will match it. If I recall, it is a very common bulb.


OK you posted as I was looking/typing...


That is the link I was looking for.





Jeep225 likes this.
__________________


'05 Rubi TJ Unlimited
'93 Toyota 4Runner
RUBI 4 MY MRS is offline   Quote
Old Today, 03:32 PM
Thread Starter
  #7
Jeeper
 
Jeep225's Avatar
 
Join Date: Aug 2017
Location: South Jersey
Posts: 302
Well the light problem was solved as I replaced all three with new bulbs.

Thanks

Jeep225 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Air Conditioning and Heater Vacuum Switch GreenBettyCLE TJ Tech Forum 5 02-02-2018 09:18 AM
Replacing AC Heater Box with Non AC box? Under the Palms TJ Tech Forum 3 10-07-2014 09:07 AM
heater/ac switch question ChrisD65 General Jeep Discussion 8 06-04-2012 03:04 PM
AR: Black Half Doors Plus Brand New Tan Soft Top Plus Half Windows $1,100 stevelucas Classifieds Archive 3 04-15-2012 07:09 AM
A/C-Heater Control Vacuum Switch Melting chrispybio TJ Tech Forum 4 02-05-2011 09:09 AM





All times are GMT -5. The time now is 06:03 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC