Help! 97 tj 4.0 engine rebuilt problems starting - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-17-2014, 08:12 PM
Thread Starter
  #1
Newb
 
Join Date: Dec 2013
Location: Alpena, Michigan
Posts: 2
Help! 97 tj 4.0 engine rebuilt problems starting

I completely rebuilt my inline 6, 4.0 engine, hard to start and when it does start it idles real rough and backfires when I give it throttle.

Replaced:
Distributor
Rotor
Cap
Wires
Plugs
Batt.

It is extremely hard to start, when it does start it idles real hard and backfires when I give it throttle.
Only code 12 and 55 given

Everything is perfectly in line with top dead center on the compression stroke.
All grounds checked out good.
Compression good on all 6.
Ignition coil is good.
Oil pressure is good.
Fuel pressure is good.
Fresh clean fuel.

Anyone else have this problem? Any help would be greatly appreciated!!!

Thank You for reading!

Regctx is offline   Quote
Old 06-17-2014, 09:59 PM   #2
Jeeper
 
DoubleOught's Avatar
 
Join Date: Feb 2014
Location: Nashville GA
Posts: 1,209
Welcome to the forum. Sounds like the timing may be off - maybe distributor is of a tooth or two.

DoubleOught is offline   Quote
Old 06-24-2014, 06:33 PM
Thread Starter
  #3
Newb
 
Join Date: Dec 2013
Location: Alpena, Michigan
Posts: 2
After a week setting the timing over and over again, found out I had bad wires and bad plugs that were bought new... Also the timing gear on the cam shaft was 180 degrees off when the dots are aligned toward each other as the Haynes manual tells you to do. If there weren't qwerks, then this wouldn't be a jeep!!
Regctx is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 08:13 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.