Intermittent rough idle - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-23-2017, 05:06 PM
Thread Starter
  #1
Jeeper
 
Join Date: Jul 2015
Posts: 34
Intermittent rough idle

Hey all, got a really annoying problem that has been going on for 2 months now. I have a 2001 60TH anniversary 4.0 Manual, and on start up ( hot or cold weather ) for bout 5-10 seconds it idles rough, truck shakes but does not go near stalling or feel like its about to. For example today was about 2 degrees but started up great this morning, revved at about 1100 before settling once warm. This evening, about the same temperature started up and idles really rough but rev counter was at about 1000. It always goes, and can easily rev to get rid of it. No other symptoms, that's it. Done all the obvious, i.e. checked spark plugs, carbon build up around TB, checked the IAC and everything does look fine. No codes coming up no check engine. I did change my O'Rings on my injectors as the old ones were cracking, but if there was an issue there surely it would be a constant poor idle?

Any ideas would be great, really need some help on this one please.....

Cheers

Chris

Chris_wrangler is offline   Quote
Old 01-23-2017, 08:06 PM   #2
Jeeper
 
Join Date: Jan 2017
Posts: 47
I have a similar issue but no solution. This is the second time I'm experiencing it. First it was due to a bad alternator, when I replaced it, everything was working fine. Then earlier today I decided to replace an o2 sensor because of a check engine light... now my car sputters at idle on a cold start....

nelor is offline   Quote
Old 01-23-2017, 10:18 PM   #3
Jeeper
 
Outdoorzman's Avatar
 
Join Date: Oct 2016
Location: Southeast Missouri - Trying to find my way to Colorado - permanently!
Posts: 370
Check your fuel pressure, on the rail. It could be a failing pressure regulator or something related to fuel pump. Knowing the numbers will help your diagnosis process.
__________________
2017 Billet Silver Jeep Wrangler Unlimited Rubicon Hard Rock, Auto, 3.73, BF Goodrich LT255/75R17C KM's, Uniden CMX760 CB Radio, Firestik FS3-B on Spare Tire Carrier Mount
Outdoorzman is offline   Quote
Sponsored Links
Advertisement
 
Old 01-24-2017, 11:10 AM   #4
Jeeper
 
nk24's Avatar
 
Join Date: Jan 2017
Location: Phoenix, AZ
Posts: 104
I have the same issue upon starting my 2000 4.0, with a very rough and inconsistent idle.

I haven't tried this yet, but found this on another forum:

4.0 high idle at start up solution finally found
nk24 is offline   Quote
Old 01-25-2017, 01:54 PM
Thread Starter
  #5
Jeeper
 
Join Date: Jul 2015
Posts: 34
Cheers guys, I have decided to take it to the dealer next week. It may be a coincidence but I have noticed it does it more when I am low on fuel, I filled up last night and its been running smooth as butter today.
Chris_wrangler is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 04:06 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.