Leak Detection Pump code P1495 when I don't have a leak detection pump - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-11-2015, 10:21 PM
Thread Starter
  #1
DMx
Newb
 
Join Date: Nov 2015
Posts: 10
Leak Detection Pump code P1495 when I don't have a leak detection pump

Hey fellas, newbie here to the forum and the jeeping world (well I've been at it a year now but just registered). Well, like the title says I'm getting the dreaded P1495 code but my 1999 TJ doesn't even have a LDP. It's a 4.0 on a Sahara with standard tranny. According to all the posts, pictures, manuals, etc. that I have looked at, the LDP should be right in front of the canister filter. All I have is the surge solenoid and the canister filter. All lines are plugged in and I don't have anything unaccounted for that I can determine with my limited knowledge. I do live in CA and purchased the vehicle here, but now as I'm trying to prep the jeep for smog so I can register it, I am getting that code. When I purchased it, it had several codes (O2 sensors (both), and vacuum leaks). I replaced the O2 sensors and the main vacuum lines, inspected all the other lines and it all looks good, but right before I replaced the vacuum lines, this one popped up and didn't clear with the reset. Has anyone encountered this or have any thoughts/suggestions? Oh and the code reappears immediately after clearing the code and turning ignition to the On position (prior to starting even, which is leading me to think it is some sort of short or other electrical issue). Please help as desert season is here and I need to smog this beast. Thank you.

DMx is offline   Quote
Old 11-12-2015, 05:58 AM   #2
Jeeper
 
Join Date: Oct 2011
Posts: 98

astro-jason is offline   Quote
Old 11-12-2015, 07:46 AM   #3
Jeeper
 
Join Date: Apr 2013
Posts: 13,017
There is one on my 1998 sport 4.0 5spd as it was on all the Cali emissions TJs in 1998

Not on the federal emissions ones

The pump is near the brake master and the previous owner thought it was ABS but since this TJ was a D44 rear from factory it never had ABS

Do a couple things

Get build sheet from Chrysler and see if your TJ was calif emissions Can be done quick and free online

Next look for the pump just in front of brake master cylinder under the hood

And finally get part number off your PCM mounted to firewall on passenger side as if the PCM is for calif emissions it will throw the code of there is not one attached
Digger84 is offline   Quote
Sponsored Links
Advertisement
 
Old 11-12-2015, 11:50 AM
Thread Starter
  #4
DMx
Newb
 
Join Date: Nov 2015
Posts: 10
Ok, thank you for the help. Here is what I found out from build sheet: built for Alabama, does have EVAP control system, but not CA emissions.
DMx is offline   Quote
Old 11-12-2015, 01:26 PM   #5
Jeeper
 
Join Date: Apr 2013
Posts: 13,017
And the PCM part number is?


If someone swapped in a calif/low emissions PCM it will expect to have the pump connected
Digger84 is offline   Quote
Old 11-13-2015, 09:24 AM
Thread Starter
  #6
DMx
Newb
 
Join Date: Nov 2015
Posts: 10
P56041466AD is the PCM, but I have no idea how to find out if that has the CA emissions on it. Any ideas?
DMx is offline   Quote
Old 11-13-2015, 09:27 AM
Thread Starter
  #7
DMx
Newb
 
Join Date: Nov 2015
Posts: 10
The void next to the purge solenoid is where the pimp should be
Attached Thumbnails
Click image for larger version

Name:	image_1447424747345.jpg
Views:	352
Size:	150.0 KB
ID:	2620161  
DMx is offline   Quote
Old 11-13-2015, 06:01 PM   #8
Jeeper
 
Join Date: Apr 2013
Posts: 13,017
Here is pic of pump
Digger84 is offline   Quote
Old 11-13-2015, 06:15 PM   #9
Jeeper
 
Join Date: Apr 2013
Posts: 13,017
So from this link post 17

https://www.wranglerforum.com/f210/19...lem-62048.html

You have a calif emissions PCM

56041466

Last letter is just minor version change so ac and ad both basically same

So you got three options
Live with code but won't get past emissions nazis

Or

Get a federal emissions PCM which should pass if your jeep is truly federal spec not calif low emissions

Or

Add the missing pump and plumbing and hope it likes it

No easy way to fool with a trick as it expects to see changes when pump is operated by PCM
Digger84 is offline   Quote
Old 11-14-2015, 10:10 AM
Thread Starter
  #10
DMx
Newb
 
Join Date: Nov 2015
Posts: 10
Digger84, thank you for your assistance, I couldn't find anything about the PCM's, that was very useful. Is that picture from your jeep? The reason I ask is I have an open electrical plug (female end) just under the surge pump and in front of the master cylinder. It isn't the same type plug as the LDP as that one requires a straight pin alignment. I'm having troubles determining what that is utilized for and wonder if that somehow ties to the LDP.
Attached Thumbnails
Click image for larger version

Name:	image_1447513793334.jpg
Views:	886
Size:	152.2 KB
ID:	2622505   Click image for larger version

Name:	image_1447513828648.jpg
Views:	338
Size:	136.5 KB
ID:	2622513  

DMx is offline   Quote
Old 11-14-2015, 11:25 AM   #11
Jeeper
 
Join Date: Apr 2013
Posts: 13,017
On my valid 98 sport 4.0 5dpd
A harness makes a Y with one fork to the brake pressure switch and other fork to connector on back side rectangularish canister then from that plug a 6 inch harness over to a plug in the pump

Also in that area just behind the canister is the cruise control servo sandwiched in front of clutch resivour and the canister and it has a harness plug to it that also came from the far side of that harness plug on the back of canister

So the mini hardness that comes out of the plug on back of canister separates into two six inch branches one to evacuate pump and other to cruise control servo
Digger84 is offline   Quote
Old 11-15-2015, 12:36 AM
Thread Starter
  #12
DMx
Newb
 
Join Date: Nov 2015
Posts: 10
Any chance you can post some pix?
DMx is offline   Quote
Old 11-15-2015, 07:54 AM   #13
Jeeper
 
Join Date: Apr 2013
Posts: 13,017
Words better
Digger84 is offline   Quote
Old 11-15-2015, 07:55 AM   #14
Jeeper
 
Join Date: Apr 2013
Posts: 13,017
H
Digger84 is offline   Quote
Old 11-15-2015, 10:22 AM
Thread Starter
  #15
DMx
Newb
 
Join Date: Nov 2015
Posts: 10
So that plug is the one that splits and goes to the LDP and the cruise control? I have that plug, but it is open; nothing plugged into it. I don't have cruise control on my rig.
DMx is offline   Quote
Old 11-15-2015, 12:00 PM   #16
Jeeper
 
Join Date: Apr 2013
Posts: 13,017
Small y harness has part number 56009925
Digger84 is offline   Quote
Old 11-15-2015, 12:04 PM   #17
Jeeper
 
Join Date: Apr 2013
Posts: 13,017
Here are more pics looks lie 6or 7 wires at plug where it starts and ends with 3 wires to pump and 4 wires to the cruise servo
Digger84 is offline   Quote
Old 11-15-2015, 01:57 PM
Thread Starter
  #18
DMx
Newb
 
Join Date: Nov 2015
Posts: 10
Awesome, thank you for taking those. I really appreciate it.
DMx is offline   Quote
Old 11-20-2015, 12:15 AM   #19
Jeeper
 
Stevenmuck's Avatar
 
Join Date: Sep 2015
Posts: 83
Does anyone know where to find a new LDP filter and filter cap? No parts stores carry them and it looks like mopar discontinued them too...
Stevenmuck is offline   Quote
Old 11-21-2015, 01:48 AM
Thread Starter
  #20
DMx
Newb
 
Join Date: Nov 2015
Posts: 10
DMx is offline   Quote
Old 11-21-2015, 01:49 AM
Thread Starter
  #21
DMx
Newb
 
Join Date: Nov 2015
Posts: 10
http://www.morris4x4center.com/filte...5085164aa.html

I screwed up the last one, this link should do the trick...
DMx is offline   Quote
Old 11-21-2015, 10:19 AM   #22
Jeeper
 
Stevenmuck's Avatar
 
Join Date: Sep 2015
Posts: 83
Okay cool, Ive seen this on some sites. I just dont know if it includes the cap AND the actual filter itself. Those are the parts I need, not necessarily the canister that holds them in the picture.

Stevenmuck is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 05:31 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.