MML help - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-25-2014, 03:20 PM
Thread Starter
  #1
Jeeper
 
Fatnot's Avatar
 
Join Date: Nov 2013
Posts: 82
MML help

I did a 1" BL & 1" MML and when I went for a test drive I get engine vibs only @ idle everything else is good no other vibs 4 x4 link work. Any suggestions

I did adjust the through bolts tight and lose no real change. I used brown dog mounts

__________________
Muddy Side Up! Rubber Side Down!
Fatnot is offline   Quote
Old 06-25-2014, 04:03 PM   #2
Jeeper
 
sccacorrado's Avatar
 
Join Date: Oct 2013
Posts: 164
Dud you completely remove the 4 transmission mount to skid plate bolts when changing the motor mounts? If not you will have ruined your transmission mount. If this is not the case then make sure the motor mount through bolts are not to tight. The nut just needs to slightly snug up to rhe rubber/poly bushings. If you overtighten the through bolts you in essence turned your new mounts into solid mounts which can be remedied by just backing off on the nuts.
Im running the Brown Dog's and love them.

Side note,

A new trans mount is nice to add when changing motor mounts if you are stull running the factory origional one.

sccacorrado is offline   Quote
Old 06-25-2014, 04:14 PM   #3
Jeeper
 
Join Date: May 2013
Location: Westchester, IL
Posts: 6,209
brown dog mounts are not nearly as forgiving as oem mounts at idle. it is normal to feel a slight vibration, at idle, when using them. they are much more rigid and our motors create more vibes at idle due to the irregular firing of an I6
Ironhead Jed is offline   Quote
Sponsored Links
Advertisement
 
Old 06-25-2014, 04:18 PM
Thread Starter
  #4
Jeeper
 
Fatnot's Avatar
 
Join Date: Nov 2013
Posts: 82
I did take the trans mount bolts off and I have had through bolt tight and loose gunna go grab a trans mount but I still think it something with bd mount
__________________
Muddy Side Up! Rubber Side Down!
Fatnot is offline   Quote
Old 06-25-2014, 04:20 PM   #5
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 48,429
Were the mounts rubber or polyurethane? Polyurethane readily passes more vibrations which is why I always recommend rubber mounts.

And what size suspension lift is installed? Installing a MML without a suspension lift will cause vibrations.
__________________
When you have a choice, buy American.
Jerry Bransford is online now   Quote
Old 06-25-2014, 05:19 PM   #6
Jeeper
 
Shoe's Avatar
 
Join Date: Jan 2010
Location: Houston, Tx
Posts: 881
I put Brown Dog mounts with rubber bushings on a 4 cyl jeep and the vibrations at idle and above 3k rpms were really annoying. I eventually went back to stock mounts with spacers and it was much better.
Shoe is offline   Quote
Old 06-25-2014, 06:44 PM   #7
Jeeper
 
Join Date: Apr 2013
Posts: 12,980
All straight four cylinders have a shaking force at twice the engine rpm

A too soft or too stiff motor mount can change the amount of vibration you feel also if frequency hits a natural harmonic the shake become real noticeable

Sometimes you get better in vehicle feel with stiffer mounts sometimes with firmer and in general factory goes for a stiffness near idea for minimum felt buzzz

Hazard of a four banger as straight six is perfectly balanced and a V8 only needs off center weights in flywheel and harmonic balancer to balance but no such option in a straight four so enjoy the buzzzzz
Digger84 is online now   Quote
Old 06-25-2014, 11:05 PM
Thread Starter
  #8
Jeeper
 
Fatnot's Avatar
 
Join Date: Nov 2013
Posts: 82
Quote:
Originally Posted by Jerry Bransford View Post
Were the mounts rubber or polyurethane? Polyurethane readily passes more vibrations which is why I always recommend rubber mounts. And what size suspension lift is installed? Installing a MML without a suspension lift will cause vibrations.
I have a 2.5" lift springs and shocks with 3/4" spacer leveling kit in the front I picked up the rubber as suggested by brown dog when I called. Think trans mount would help ?

__________________
Muddy Side Up! Rubber Side Down!
Fatnot is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 08:26 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.