NEED HELP: Instrument cluster fail to ceased engine? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-29-2019, 08:00 AM
Thread Starter
  #1
Newb
 
KPJeepLyfe's Avatar
 
Join Date: Jul 2019
Posts: 4
NEED HELP: Instrument cluster fail to ceased engine?

Hi All,

I'm looking for some guidance on my 2001 Sahara TJ. I recently purchased the car from a private seller in CT and after a month of use, I realized that the instrument cluster was whacky (temp and oil gauge jumping up and down). After bringing it to the shop, they determined it needed to be reset and sent it to some guy in the Mid-West to fix it. Got it back... and the needles were right in the middle.

Here's the issue... after driving the car for 2 days, I started the car to a hard start. After driving a few miles, I heard a whirling/squeeking noise and then noticed the temp gauge climbing. At first I suspected that the instrument cluster was never fully fixed, but then I started smelling rubber and when I slowed the car idled like junk... and then the smoke came from under the hood... and before I could pull over to a safe place the car just stopped.

I brought it into the shop and the mechanic claims that the engine is shot and wants to charge me $7k to replace. But how does this just happen? Was this because they hooked up the instrument cluster wrong? The car was riding perfectly before this.

Please HELP! I've been dumping money into this Jeep and really would like to know how to discuss this issue with the mechanic if they are related.


Forever grateful for you all,
KPJeepLyfe

KPJeepLyfe is offline   Quote
Old 07-29-2019, 08:40 AM   #2
Jeeper
 
Join Date: Apr 2013
Posts: 12,706
2000 2001 4.0 have a crack prone head which forced a tupy redesign by Chrysler/Jeep

If the head develops the crack coolant level drops as coolant enters the crankcase and mixes with the oil

This coolant oil mix is a poor lubricant and destroys engine

Cluster did not cause this as it only reads data but being unaware of over temp and not monitoring oil level increase or coolant decrease may have contributed

If you continue to run overheated engine looking for safe place to pull over expect to risk major engine damage - live and learn but it will cost you

Original sale may have been after discovered crack in head
They change oil top off coolant and sell it quick - buyer beware - live and learn


Sent from my iPhone using Tapatalk
Digger84 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 03:12 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC