New Oil Pump Installed, Now No Oil Pressure!!! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-12-2011, 08:16 PM
Thread Starter
  #1
Jeeper
 
JDaviesspy's Avatar
 
Join Date: Dec 2010
Location: North Florida
Posts: 23
New Oil Pump Installed, Now No Oil Pressure!!!

I just installed a new oil pump in my 4.0 6Cyl, replaced the oil pan and the 1000 bolts, filled with fresh oil and started her up to find check gauge light on and no oil pressure. I ran the engine for about 2 minutes, but did not see oil pumping up into the valves...

I checked the OP sensor and it is fine. Does it take a while to prime or do I have a bad pump?

I am truly dreading having to remove the exhaust and drop the oil pan again....


HELP!!!!!

JDaviesspy is offline   Quote
Old 02-12-2011, 08:25 PM   #2
Jeeper
 
just4fun's Avatar
 
Join Date: Feb 2011
Posts: 8,424
Did u prime the pump before u installed it. Pull the spark plugs and crank the engine over. U may need to pull vavle cover while u crank it over and see if u get oil to the top of the head

just4fun is offline   Quote
Old 02-12-2011, 08:29 PM
Thread Starter
  #3
Jeeper
 
JDaviesspy's Avatar
 
Join Date: Dec 2010
Location: North Florida
Posts: 23
I guess priming it would have been a good idea if I had thought about it.....which I didn't!!! Is there anyway to do this without removing it again????


Thanks!!!!
JDaviesspy is offline   Quote
Sponsored Links
Advertisement
 
Old 02-12-2011, 08:36 PM   #4
Jeeper
 
just4fun's Avatar
 
Join Date: Feb 2011
Posts: 8,424
Im not sure if their is an oil pump priming tool that works with a drill for a jeep. It works by removing the distributor. I would pull the spark plugs so the engine cranks without compression on it and remove valve cover to see if you get oil to the top of the head and then you know it works
just4fun is offline   Quote
Old 02-12-2011, 09:03 PM
Thread Starter
  #5
Jeeper
 
JDaviesspy's Avatar
 
Join Date: Dec 2010
Location: North Florida
Posts: 23
Thanks...... I found this while searching and sounds just as you instructed. I truly appreciate your advice and time!

Cheers, Jason

Priming the oil pump engine

The best way to prime an engine is with a priming rod....available through mopar performance. The distributor needs to be removed and the oil pump drive gear as well. the rod is inserted into the oil pump and attached to a reversable drill....the drill must be spun counterclockwise for the pump to prime....because that is the rotational direction of the engine.

The easy way is to pull the coil wire and disconnect the fuel pump on the inlet side before the pump. You want the fuel supply disconnected because the carb will dump raw fuel into the motor and wash down the cylinder walls....not good. When youve done those two things, simply crank the motor over for 20-30 seconds in short 10 second bursts and look at the oil pressure guage for a reading. This method works fine for mild motors with some milage on the clock. As long as the motor hasnt been sitting for a year or so it will work good. I would not recommend this procedure on a freshly rebuilt motor....those need to be primed with the method outlined above.
JDaviesspy is offline   Quote
Old 02-12-2011, 09:07 PM   #6
Jeeper
 
just4fun's Avatar
 
Join Date: Feb 2011
Posts: 8,424
Goodluck I hope it works
just4fun is offline   Quote
Old 02-12-2011, 11:46 PM   #7
Jeeper
 
bc3_Jeep's Avatar
 
Join Date: Nov 2010
Location: NE corner of Iowa
Posts: 1,738
I have....in a pinch...cut down an old screwdriver and used it as a priming rod......grinding/turning the end so it would fit in my drill....
__________________
"For Gawd's sake, put a RELAY in there or you could burn the whole damn Jeep to the ground" ...this quote brought to you by people who do not understand the law.....Kirchoff's, Ohm's, or Faraday's.
Violation of KISS shall always ring false in TRUE engineering. - ME___
Had 75CJ5, 89YJ, 93YJ. Have 82CJ7 & 95YJ____Not one burnt yet due to lack of relays.
bc3_Jeep is offline   Quote
Old 02-13-2011, 12:01 AM   #8
Jeeper
 
bc3_Jeep's Avatar
 
Join Date: Nov 2010
Location: NE corner of Iowa
Posts: 1,738
One other thing that the old timers used to do......pack the oil pump full of vaseline before reassembly....... to "provide prime" from below....
__________________
"For Gawd's sake, put a RELAY in there or you could burn the whole damn Jeep to the ground" ...this quote brought to you by people who do not understand the law.....Kirchoff's, Ohm's, or Faraday's.
Violation of KISS shall always ring false in TRUE engineering. - ME___
Had 75CJ5, 89YJ, 93YJ. Have 82CJ7 & 95YJ____Not one burnt yet due to lack of relays.
bc3_Jeep is offline   Quote
Old 02-13-2011, 08:32 AM
Thread Starter
  #9
Jeeper
 
JDaviesspy's Avatar
 
Join Date: Dec 2010
Location: North Florida
Posts: 23
Thanks bc3 Jeep. I should have primed it before closing everything up, but missed that important part. I will be making my tool and priming it today!

Thanks for the advice!!!!
JDaviesspy is offline   Quote
Old 02-13-2011, 11:00 AM
Thread Starter
  #10
Jeeper
 
JDaviesspy's Avatar
 
Join Date: Dec 2010
Location: North Florida
Posts: 23
So, after making the tool out of a cheap screwdriver, placing it on a reversible drill (All instructions state it must run counter clockwise), running it for 30 minutes and still no prime...... I looked at the distributor rotation chart and noticed that it rotates CLOCKWISE!!!! Flipped the switch to clockwise and the pump started to prime within 30 seconds! Will update you all when I get her up an drunning to see if it maintains good pressure!
JDaviesspy is offline   Quote
Old 02-13-2011, 12:21 PM
Thread Starter
  #11
Jeeper
 
JDaviesspy's Avatar
 
Join Date: Dec 2010
Location: North Florida
Posts: 23
All done..... Great pressure, way better than before!!!! $200 in parts and my labor. I replaced the Oil pump, oil pan seal, rear main seal (had to use 2 kits due to the first top seal sheared a little when installing) and valve cover gasket..... so far no leaks

Once again, Thanks for all the advice folks!!!
JDaviesspy is offline   Quote
Old 02-13-2011, 10:41 PM   #12
Jeeper
 
bc3_Jeep's Avatar
 
Join Date: Nov 2010
Location: NE corner of Iowa
Posts: 1,738
Good news..... and THANK YOU VERY MUCH for the update...... too many times.... advice is given and no updates are forthcoming......

I sincerely hope you never have to do this again......ROTFLMAO......

__________________
"For Gawd's sake, put a RELAY in there or you could burn the whole damn Jeep to the ground" ...this quote brought to you by people who do not understand the law.....Kirchoff's, Ohm's, or Faraday's.
Violation of KISS shall always ring false in TRUE engineering. - ME___
Had 75CJ5, 89YJ, 93YJ. Have 82CJ7 & 95YJ____Not one burnt yet due to lack of relays.
bc3_Jeep is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
92 YJ 2.5 Won't start, no power to the fuel pump eyeChrs YJ Tech Forum 15 02-14-2012 05:46 PM
Oil Pressure drop, DD need help quick! Under the Palms TJ Tech Forum 12 10-04-2010 04:56 PM
2000 jeep wrangler fuel pump replacement madmilitia TJ Tech Forum 16 07-08-2010 04:40 PM
98 4.0 fuel pump problem mishkajb TJ Tech Forum 1 04-30-2010 02:23 PM
intermittant power to fuel pump skeeter General Jeep Discussion 4 02-08-2009 09:22 PM





All times are GMT -5. The time now is 12:59 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.