Oil Pressure Issue - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-17-2014, 01:22 AM
Thread Starter
  #1
Jeeper
 
uniballer's Avatar
 
Join Date: May 2012
Location: STL.MO.USA
Posts: 142
Oil Pressure Issue

Something odd just started happening with my 2004 TJ, the oil pressure gauge will drop to zero, it flashes the "check gauges" light and beeps, then it goes right back to normal operating pressure before i even have a chance to pull over or kill the ignition.

It has only happened a few times so far, like 3 or 4, I've only observed it within the first few minutes of driving it. While it's due for an oil change anyway, it never occurred before replacing the battery 2 weeks ago. I haven't yet been able to identify any similar factors between incidents (like right after shifting to 3rd, braking, during hard turns, or whatever).

While I guess it could be related to the battery swap, I don't see any other indicators that the battery is bad or in any way goofy. So my initial thought is a loose wire on the Oil Sending Unit, or a bad unit altogether. Since I'm not going to have a chance to dig into it until next weekend so I thought I'd run this by you guys in case one of you have had this exact same problem and would care to share the fix.

Barring specific input, this is what I plan to do next weekend.

- Replace Oil Sending Unity
- Change Oil and Filter
- Check the wiring for any obvious problems

Thanks in advance for any input!

__________________
2004 Rubicon
uniballer is offline   Quote
Old 02-17-2014, 08:13 AM   #2
Jeeper
 
NC Bear's Avatar
 
Join Date: Jun 2012
Location: North Carolina
Posts: 2,186
get the factory OEM oil pressure switch. The ones at the parts box stores are garbage.

I found that mine does it once my oil gets close to time to change the oil.
__________________
My daily driver is a 2015 JKU on 35's 4.56 and Trutracs, My trail rig is my 1997 TJ on 35's 4.88 and Trutracs plus a pile of cash....
NC Bear is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 01:18 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.