Passenger side clicking... - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-08-2015, 02:35 PM
Thread Starter
  #1
Newb
 
Join Date: Feb 2015
Posts: 3
Passenger side clicking...

Last night I heard an on/off clicking noise from what seemed like underneath the passenger side dash. I assumed a fuse of some sort, did a quick search and found a couple of threads that stated it may be a relay issue attached to a few different options. Made it home last night and didn't drive again or research further.

This morning, I ran a couple of errands, got gas, turned my Jeep on and off a couple of times without issue. Stopped at the grocery store, came back out and turned it on normal. I went to back out of my spot, reversed and then as I put it in first, I thought I had stalled which was odd, had given it plenty of gas, it died. Everything, blank, no dash, no stereo, no alternator clicks no nothing. I do have a kill switch which was installed by the previous owner, but it still allows for electrical when engaged (can start without the clutch pedal being depressed if that comes into play?). I flipped that switch a couple of times and still nothing.

I get a push out of the way, forward some back some and then forward again trying to get into a parking spot to leave it for a moment and diagnose. Just as I'm almost in, I go to try it and turn the key forward, boom, music, lights, engine, action. Everything seems to be operating normally.

Any ideas where to start or what I can look at to try and avoid this happening again the future?

Let me know if I can provide any more pertinent information. 2002, battery terminals secure, maybe a little dirty but not corroded. Battery reads well, only about a year old.

Thanks for reading.

LateNightTJ is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 04:58 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.