Please Help!!! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-25-2013, 08:46 PM
Thread Starter
  #1
Newb
 
Soldier83's Avatar
 
Join Date: Jun 2013
Posts: 3
Please Help!!!

I have a 1998 Wrangler with over 150K miles on it. For a few weeks now its been giving me issues. If I drive it for more than 10 minutes (say to the store or something) I have to wait 30 to 40 minutes before I can started back up. When I try to started it sounds like it has no gas. In the pass few days It has started back firing and sputtering while I am driving. Also if I press the gas pedal to pass someone it actually looses power and slows down. I notice black smoke coming from the exhaust this morning when I started it.

Things I have done so far:
Oil Change
Replace Spark Plug and wires
Replace the Map Sensor
Replace fuel filter and strainer
Replace Distributor Cap

I took it for a diagnostic test and these are the code they gave me.
Fuel System Bank 1 Sensor 1 P0171
Loss of Camshaft Crank P1391
O2 Sensor #2 P0138

What should I do next? Any input will be appreciated.

Soldier83 is offline   Quote
Old 06-25-2013, 09:09 PM   #2
Jeeper
 
Join Date: Apr 2013
Location: Connecticut
Posts: 232
Change your O2 sensors. Engine could be running rich and getting "flooded" after the short trips. This is further shown by the black smoke coming out of the tailpipe, which is another sign of an engine getting too much gas. Also, an engine receiving the incorrect air/fuel mixture would be most evident under heavy load, like when you try to pass a car. Change the O2 sensors and I believe you'll correct all these issues.

The only one I'm unsure about is the P1391 code. I think this might be unrelated, and you may need a new CPS.

__________________
2003 Jeep Wrangler X 4.0L ~ 107,000 miles
apannone is offline   Quote
Old 06-25-2013, 09:20 PM   #3
Jeeper
 
TJ4Jim's Avatar
 
Join Date: Feb 2012
Location: Brookings, Oregon
Posts: 3,165
Possibly the CAT is on the way out. Typical symptoms.
TJ4Jim is offline   Quote
Sponsored Links
Advertisement
 
Old 06-25-2013, 09:22 PM   #4
Jeeper
 
Join Date: Apr 2013
Location: Connecticut
Posts: 232
Quote:
Originally Posted by JimsJeep View Post
Possibly the CAT is on the way out. Typical symptoms.
Bad cat will cause a no start condition?
__________________
2003 Jeep Wrangler X 4.0L ~ 107,000 miles
apannone is offline   Quote
Old 06-25-2013, 09:37 PM   #5
Jeeper
 
TJ4Jim's Avatar
 
Join Date: Feb 2012
Location: Brookings, Oregon
Posts: 3,165
Yes until it cools down. Had a similar problem in a Rav 4. Exact same symptoms , step on the gas and it bogged down. Would just stall at random.
TJ4Jim is offline   Quote
Old 06-25-2013, 09:45 PM   #6
Jeeper
 
Join Date: Apr 2013
Location: Connecticut
Posts: 232
Good to know!
__________________
2003 Jeep Wrangler X 4.0L ~ 107,000 miles
apannone is offline   Quote
Old 06-25-2013, 09:51 PM   #7
Jeeper
 
Brankz's Avatar
 
Join Date: Jun 2013
Posts: 348
Gas relay!!!!!!! Check that out
Brankz is offline   Quote
Old 06-28-2013, 07:20 PM
Thread Starter
  #8
Newb
 
Soldier83's Avatar
 
Join Date: Jun 2013
Posts: 3
Thanks everyone!
Soldier83 is offline   Quote
Old 06-28-2013, 07:38 PM   #9
Newb
 
Rob3811's Avatar
 
Join Date: Dec 2011
Location: Gilbert, AZ
Posts: 10
Quote:
Originally Posted by apannone View Post
Change your O2 sensors. Engine could be running rich and getting "flooded" after the short trips. This is further shown by the black smoke coming out of the tailpipe, which is another sign of an engine getting too much gas. Also, an engine receiving the incorrect air/fuel mixture would be most evident under heavy load, like when you try to pass a car. Change the O2 sensors and I believe you'll correct all these issues.

The only one I'm unsure about is the P1391 code. I think this might be unrelated, and you may need a new CPS.
P1391 is Crank sensor, Clear all codes and replace the up stream o2 sensor that should fix the miss with your other troubles.

__________________
1998 Jeep Wrangler Sport 5 speed
4.6 Golen Stroker/Custom intake/ARB Compressor
Full exhaust/Header/highflow Cat/flowmaster
6 inch lift /slip-yoke eliminator/Tom Woods d-shaft
5 layer brake lines
37's Goodyear Wrangler MT
Rob3811 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 03:49 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.