Please help code po442 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-31-2011, 04:22 AM
Thread Starter
  #1
Jeeper
 
Jason1348's Avatar
 
Join Date: Oct 2011
Posts: 646
Please help code po442

Well I know it could be gas cap or broken or cracked rubber line any one ever get this code and what did u do to fix

Jason1348 is offline   Quote
Old 10-31-2011, 05:23 AM   #2
Jeep Ninja

WF Supporting Member
 
scgeek12's Avatar
 
Join Date: Feb 2011
Location: Norfolk VA
Posts: 1,835
you can bring it to a shop and have it smoke tested to find the leak, but id try a new gas cap first, its cheaper

__________________
"if it aint broke, fix it till' it is!"
my build- https://www.wranglerforum.com/f5/scge...ad-117592.html
scgeek12 is offline   Quote
Old 10-31-2011, 10:12 AM   #3
Jeeper
 
jgorm's Avatar
 
Join Date: May 2010
Location: San Diego
Posts: 1,924
That is a catalytic efficiency code, not an evap code.
P0422 Main Catalyst Efficiency Below Threshold (Bank 1)
OBD-II Check Engine Light Trouble Codes
Try new O2 sensors first, then replace the cats.
__________________
my 06 LJ rubicon
2.5" SL, 1" BL, DIY highline, 35s with double beadlocks.
jgorm is offline   Quote
Sponsored Links
Advertisement
 
Old 10-31-2011, 01:26 PM   #4
Jeep Ninja

WF Supporting Member
 
scgeek12's Avatar
 
Join Date: Feb 2011
Location: Norfolk VA
Posts: 1,835
o, was just going by the face he said he knew it could be a bad gas cap lol
__________________
"if it aint broke, fix it till' it is!"
my build- https://www.wranglerforum.com/f5/scge...ad-117592.html
scgeek12 is offline   Quote
Old 10-31-2011, 01:48 PM   #5
Jeeper
 
TOKKIE's Avatar
 
Join Date: Mar 2010
Location: Sonora, CA.
Posts: 431
His code is a p0442, not p0422. P0442 is an evap code.
TOKKIE is offline   Quote
Old 10-31-2011, 01:51 PM   #6
Jeep Ninja

WF Supporting Member
 
scgeek12's Avatar
 
Join Date: Feb 2011
Location: Norfolk VA
Posts: 1,835
well than im back to saying toss on a new gas cap and if that doesnt work, smoke test her
__________________
"if it aint broke, fix it till' it is!"
my build- https://www.wranglerforum.com/f5/scge...ad-117592.html
scgeek12 is offline   Quote
Old 10-31-2011, 01:55 PM   #7
▄▌ee▐▀

WF Supporting Member
 
Hardermods's Avatar
 
Join Date: Jul 2009
Location: Kansas
Posts: 1,789
Also pop your hood and look on the drivers side inner fender. Your evap canister/purge valve is all mounted there. Check the hoses going to them for any rot, cracks. They tend to crack an cause evap codes.
Hardermods is offline   Quote
Old 10-31-2011, 03:13 PM
Thread Starter
  #8
Jeeper
 
Jason1348's Avatar
 
Join Date: Oct 2011
Posts: 646
Tightened the gas cap cleared the code with the reader and see how that does
Jason1348 is offline   Quote
Old 10-31-2011, 03:40 PM   #9
Jeeper
 
jasonduke5's Avatar
 
Join Date: Sep 2011
Location: Williamsport P>A
Posts: 435
I had the same code went to the shop and had the gas cap tested and it was fine. had it smoked tested and it was the gas cap. There was nothing wrong with the cap. It was just the wrong cap for my jeep. I was a little upset. Cost me 175 buck for a smoke test to tell me it was the wrong treads on the gas cap. I felt really really stupid.
jasonduke5 is offline   Quote
Old 02-24-2012, 11:18 PM   #10
Jeeper
 
danbooth's Avatar
 
Join Date: Jan 2008
Location: Jacksonville, FL
Posts: 15
Was your gas cap OEM?
danbooth is offline   Quote
Old 02-25-2012, 07:52 PM   #11
Jeeper
 
Join Date: Mar 2011
Location: Lexington, NC
Posts: 493
Had this recently. Changed gas cap, nogo. Ended up being a rotted end on a hose at the evap pump. Also found one at the manifold so fixed that too. Just start it up and listen carefully close to where the lines run. Cheaper than the smoke test and you will hear it.
user4574 is offline   Quote
Old 02-25-2012, 11:35 PM   #12
Show Me Your 8008135!

WF Supporting Member
 
s3nt3nc3d's Avatar
 
Join Date: Oct 2009
Location: Piqua, OH
Posts: 3,641
Send a message via AIM to s3nt3nc3d
I've had a CEL on with that code for a year now... I said screw it. Smoke tested twice...couldn't find the leak. Replaced gas cap and leak detection pump, still no luck.

My gas mileage is fine so I've just never messed with it...one of these days, I'll smoke it again and see if I can find it. Somebody said you gotta smoke it with the leak detection pump manually opened with a diagnostic computer or something like that...so my buddy is a mechanic and has both a diagnostic computer and a smoke tester and I'll give it a go.
__________________
"We don't build great brakes because we think you don't know how to drive, we build them for the guy on the road in front of you that doesn't." - Black Magic Brakes
s3nt3nc3d is offline   Quote
Old 02-26-2012, 11:03 AM   #13
Jeeper
 
jgorm's Avatar
 
Join Date: May 2010
Location: San Diego
Posts: 1,924
I smoke tested my jeep twice and didn't find an evap leak (small leak detected code). I pulled every hose and put plumbers grease on it and hose clamped all of them and the code went away. I put hose clamps on before doing the grease and I still had the code.
__________________
my 06 LJ rubicon
2.5" SL, 1" BL, DIY highline, 35s with double beadlocks.
jgorm is offline   Quote
Old 02-26-2012, 11:37 AM   #14
Jeeper
 
Join Date: Dec 2011
Location: Hill Country
Posts: 769
Had same problem, change gas cap and clear code, will likely fix problems
Tdog02 is offline   Quote
Old 09-19-2012, 03:27 AM   #15
Jeeper
 
Join Date: Apr 2009
Posts: 63
Quote:
Originally Posted by jgorm View Post
I smoke tested my jeep twice and didn't find an evap leak (small leak detected code). I pulled every hose and put plumbers grease on it and hose clamped all of them and the code went away. I put hose clamps on before doing the grease and I still had the code.
Hey J, how did you know which hoses to clamp and grease? You don't have a diagram or schematic do you?
TheBostonWrangler is offline   Quote
Old 09-19-2012, 06:56 AM   #16
Jeeper
 
Jaba04's Avatar
 
Join Date: Aug 2012
Location: Indianapolis
Posts: 41
I had a similar situation this summer. Took it to Firestone (cheapest for a smoke test in the area). They told me the gas cap, leak detection pump, and the purge valve were all shot and needed to be replaced (approximately $450.00). I wonder if they weren't just blowing smoke in more ways than one...

Jaba04 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OBDII Code 2096 Marnix TJ General Discussion Forum 8 08-02-2014 09:11 PM
2.5L with code P0132, poor idle, lacks power nittanylns TJ Tech Forum 13 08-06-2010 09:45 PM
P0700 code, what to do and why only this code? Dixit TJ General Discussion Forum 18 07-10-2010 12:31 PM
P0605 code Old Blue TJ Tech Forum 3 08-29-2009 08:33 PM
Odd LJ paint code question rallykid TJ General Discussion Forum 3 01-06-2009 11:51 AM





All times are GMT -5. The time now is 07:50 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.