Problem starting - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-16-2014, 10:02 AM
Thread Starter
  #1
Jeeper
 
moxie_one's Avatar
 
Join Date: Nov 2013
Posts: 74
Problem starting

Need some help. 03 Sahara 4.0, having trouble starting it in the morning, and then through out the day if it sits for a couple of hours. It got worse today when I attempted to make a 3 point turn and stalled out while I was in reverse! I had it idling for 15-20+ mins before that It,which normally seems to help it. It does have a very slight flutter at idle which makes me think IAC,but I have to pump the gas to start it and have to keep rpm's up for a few mins so it won't stall. Which makes me think fuel delivery. But also read on here could be Dirty throttle body or plugs and wires! doesn't seem to be a battery issue. Bought it used about a moth ago, has 125k on it now and was running very well when I got it. I think it just might have been time for fuel pump or something to go but I don't know enough mechanically to zero in on it. Any and all help is greatly appreciated.

moxie_one is offline   Quote
Old 01-16-2014, 10:11 AM   #2
Jeeper
 
Mr Mac's Avatar
 
Join Date: Nov 2011
Location: Montgomery, AL
Posts: 2,729
Start with cleaning the TB and fuel system and make sure your air filter is good. Run a couple of tanks with a good fuel system cleaner (Tekron is a good one) and see how it does after that.

__________________
But the wisdom that is from above is first pure, then peaceable, gentle, and easy to be intreated, full of mercy and good fruits, without partiality, and without hypocrisy. James 3:17 (KJV)


Mr Mac is offline   Quote
Old 01-16-2014, 10:59 AM
Thread Starter
  #3
Jeeper
 
moxie_one's Avatar
 
Join Date: Nov 2013
Posts: 74
Quote:
Originally Posted by Mr Mac View Post
Start with cleaning the TB and fuel system and make sure your air filter is good. Run a couple of tanks with a good fuel system cleaner (Tekron is a good one) and see how it does after that.
I'll start there thanks
moxie_one is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 02:56 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.