Rough start/idle Help - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-23-2019, 07:07 AM
Thread Starter
  #1
Jeeper
 
n0useforaname's Avatar
 
Join Date: May 2016
Posts: 47
Rough start/idle Help

Yes I've read the 1000 posts from other people on fuel pump, turning key 4 times, fuel pressure, wires, plugs, etc.. but this is a bit different IMO.


In short, randomly over the past 3 years jeep would start instantly, like key forward, instant start. On occasion, 100 yards down the road engine would bog like it's starving for fuel or air for 2-3 seconds, come back and run 100% fine, never do it again. Very random. Past week I hold key for 3-4 seconds before it starts, then it spits/sputters for about 30 seconds until it runs 100% fine after.



I've replaced: clock spring, TPS, IAC, MAF, CPS, entire fuel pump 3 times, cleaned throttle body, air intake, plugs, wires, exhaust, fuel cap, and filler neck. And yes... everything is OEM from the dealership, no autozone or napa stuff. I don't mind spending the cash needed on my rig.



At this point I ordered a new distributor cap and rotor... next maybe 02 sensors?? NO CODES EVER! No blown fuses, no electrical issues, nothing else. Engine only has around 100K on it. Just curious if anyone has any ideas? I thought maybe injector related/etc.. but it holds pressure and runs 100% fine after starting and giving it 30 seconds.



Thanks in advance!

__________________
99 Wrangler Sport 4.0 Auto - 4.10 gearing
3.5" lift - 33X12.50/18
Currie currectlync and front track bar
Redhead steering box - Cervinis cowl hood
doubleDIN center mod w rear seat 10" sub mod
bed tred carpet w raptorlined dash/plastic
n0useforaname is offline   Quote
Old 08-23-2019, 07:20 AM   #2
Jeeper
 
Join Date: Apr 2013
Posts: 12,691
Low probability of success but zero cost

Check tub to engine ground both ends clean and tight

That intermittent sure sounds like wiring

Also look closely at harness at top of rear battery hold down bolt make sure no rubbing/wearing into harness


Sent from my iPhone using Tapatalk

Digger84 is offline   Quote
Old 08-23-2019, 08:11 AM
Thread Starter
  #3
Jeeper
 
n0useforaname's Avatar
 
Join Date: May 2016
Posts: 47
Quote:
Originally Posted by Digger84 View Post
Low probability of success but zero cost

Check tub to engine ground both ends clean and tight

That intermittent sure sounds like wiring

Also look closely at harness at top of rear battery hold down bolt make sure no rubbing/wearing into harness


Sent from my iPhone using Tapatalk

I actually checked and replaced my ground wires too, forgot to mention that. Also pulled battery and checked connections there, and removed rear tail lights, front turns, heads and rewired, greased and soldered connections and taped them up good. I should also mention that when it intermittently did this in the past, it was usually damp/wet or humid out.
__________________
99 Wrangler Sport 4.0 Auto - 4.10 gearing
3.5" lift - 33X12.50/18
Currie currectlync and front track bar
Redhead steering box - Cervinis cowl hood
doubleDIN center mod w rear seat 10" sub mod
bed tred carpet w raptorlined dash/plastic
n0useforaname is offline   Quote
Sponsored Links
Advertisement
 
Old 08-23-2019, 08:59 AM   #4
Jeeper
 
jgalvar's Avatar
 
Join Date: Aug 2014
Location: AL
Posts: 89
Delete

Sent from my Pixel using Tapatalk
__________________
99' TJ 4.0
Zone Combo lift 4.25", JKS Front Track Bar, 33x12.5x15 Cooper STT on Cragar 8, Smitty XRC Rear and Swing, Barricade Trail Trail Force HD Front, Warn M8000, Q-Discos, cb, Polk Audio
BUILD PROGRESS with PICS
jgalvar is offline   Quote
Old 08-23-2019, 01:12 PM
Thread Starter
  #5
Jeeper
 
n0useforaname's Avatar
 
Join Date: May 2016
Posts: 47
new distributor and rotor will be here tonight, hopefully that works. Fingers crossed
__________________
99 Wrangler Sport 4.0 Auto - 4.10 gearing
3.5" lift - 33X12.50/18
Currie currectlync and front track bar
Redhead steering box - Cervinis cowl hood
doubleDIN center mod w rear seat 10" sub mod
bed tred carpet w raptorlined dash/plastic
n0useforaname is offline   Quote
Old 08-27-2019, 06:17 PM
Thread Starter
  #6
Jeeper
 
n0useforaname's Avatar
 
Join Date: May 2016
Posts: 47
New distributor did not work. What else should i be looking at? Already did new plugs, wires, etc. could the starter itself be bad? Computer test said O2 sensors are good


Sent from my iPhone using Tapatalk
__________________
99 Wrangler Sport 4.0 Auto - 4.10 gearing
3.5" lift - 33X12.50/18
Currie currectlync and front track bar
Redhead steering box - Cervinis cowl hood
doubleDIN center mod w rear seat 10" sub mod
bed tred carpet w raptorlined dash/plastic
n0useforaname is offline   Quote
Old 08-29-2019, 10:26 PM
Thread Starter
  #7
Jeeper
 
n0useforaname's Avatar
 
Join Date: May 2016
Posts: 47
tested all electrical stuff to starter, it was fine. Also just put on a new ignition coil and it did nothing. Maybe thinking 02 sensors now. Anyone?
__________________
99 Wrangler Sport 4.0 Auto - 4.10 gearing
3.5" lift - 33X12.50/18
Currie currectlync and front track bar
Redhead steering box - Cervinis cowl hood
doubleDIN center mod w rear seat 10" sub mod
bed tred carpet w raptorlined dash/plastic
n0useforaname is offline   Quote
Old 08-30-2019, 05:45 AM   #8
Jeeper
 
Join Date: Apr 2013
Posts: 12,691
Intermittent is wiring till proven otherwise
Strongly recommend you stop throwing random parts at the problem


Sent from my iPhone using Tapatalk
Digger84 is offline   Quote
Old 08-30-2019, 06:48 AM
Thread Starter
  #9
Jeeper
 
n0useforaname's Avatar
 
Join Date: May 2016
Posts: 47
Quote:
Originally Posted by Digger84 View Post
Intermittent is wiring till proven otherwise
Strongly recommend you stop throwing random parts at the problem


Sent from my iPhone using Tapatalk

As of the past couple weeks, it's not intermittent anymore. Although after reading through 100 threads last night, I may have an injector leak. My uncle did a pressure test and it sat around 48 PSI.. but when the engine was off it was like 20 or lower which from my understanding, it should sit at 48 for quite awhile. I have already replaced my pump and the check valves, and I noticed for about 5 seconds after it starts it tends to spit/sputter until I get moving. I also tend to smell like a fuel/burnt oil/fuel smell after it starts. So I'm gonna take the rail off and prime it to see if any of them leak.


And if the parts are cheap enough I don't mind throwing them at it honestly. I love the jeep, gonna have it for a LONG time, so the newer and more reliable I make it... the better.
__________________
99 Wrangler Sport 4.0 Auto - 4.10 gearing
3.5" lift - 33X12.50/18
Currie currectlync and front track bar
Redhead steering box - Cervinis cowl hood
doubleDIN center mod w rear seat 10" sub mod
bed tred carpet w raptorlined dash/plastic
n0useforaname is offline   Quote
Old 08-30-2019, 07:30 AM   #10
Jeeper
 
Join Date: Apr 2013
Posts: 12,691
Except not all new parts are good so it does not prove that the replaced part was not the problem and it has the potential to replace a working part with a defective one complicating the problems

Perhaps replacing a good part is what caused the now not intermittent issue

Looking for problems as you now propose is far more effective
Ready aim fire gets better results then ready fire aim almost every time


Sent from my iPhone using Tapatalk
Digger84 is offline   Quote
Old 08-30-2019, 07:35 AM   #11
Jeeper
 
Join Date: Apr 2013
Posts: 12,691
Quote:
Originally Posted by Digger84 View Post
Except not all new parts are good so it does not prove that the replaced part was not the problem and it has the potential to replace a working part with a defective one complicating the problems

Perhaps replacing a good part is what caused the now not intermittent issue

Looking for problems as you now propose is far more effective
Ready aim fire gets better results then ready fire aim almost every time


Sent from my iPhone using Tapatalk


As for leak down
My 98 sport can sit a month and even if I forget to undo kill switch that interrupts power to fuel pump it will start and run several seconds on the residual pressure from last running a month ago then sputter and die to remind me to undo kill switch

If pressure pisses away Leak can be at either end (injector or pump regulator) but several priming runs before start attempt makes for normal start if at pump regulator end whereas the extra fuel in the manifold from a leaky injector should still cause start up mixture issue if a leaky injector


Sent from my iPhone using Tapatalk
Digger84 is offline   Quote
Old 08-30-2019, 10:23 AM
Thread Starter
  #12
Jeeper
 
n0useforaname's Avatar
 
Join Date: May 2016
Posts: 47
I def. think it's at the manifold. My pump was bad a year ago, i could prime key 3 times and it was perfect everytime. Replaced pump, no issues with that since then. The fact that it's hard to start, drops to 20PSI sitting, and spits/sputters on start up is making me think injector. I'll mess with in this weekend and report back.
__________________
99 Wrangler Sport 4.0 Auto - 4.10 gearing
3.5" lift - 33X12.50/18
Currie currectlync and front track bar
Redhead steering box - Cervinis cowl hood
doubleDIN center mod w rear seat 10" sub mod
bed tred carpet w raptorlined dash/plastic
n0useforaname is offline   Quote
Old 09-01-2019, 08:31 PM
Thread Starter
  #13
Jeeper
 
n0useforaname's Avatar
 
Join Date: May 2016
Posts: 47
Not that many people are following this thread but i tore the fuel rail off and checked injectors tonight.. NO leaks and they spit perfectly. Hooked up pressure gauge and it goes from 50 to 0 instantly on shut off. Looks like my 10 month old pressure regulator is bad.. time for another pump replacement.


Sent from my iPhone using Tapatalk
__________________
99 Wrangler Sport 4.0 Auto - 4.10 gearing
3.5" lift - 33X12.50/18
Currie currectlync and front track bar
Redhead steering box - Cervinis cowl hood
doubleDIN center mod w rear seat 10" sub mod
bed tred carpet w raptorlined dash/plastic
n0useforaname is offline   Quote
Old 09-01-2019, 08:40 PM   #14
Jeeper
 
Join Date: Apr 2013
Posts: 12,691
Sounds correct


Sent from my iPhone using Tapatalk
Digger84 is offline   Quote
Old 09-05-2019, 08:08 PM
Thread Starter
  #15
Jeeper
 
n0useforaname's Avatar
 
Join Date: May 2016
Posts: 47
Pump replaced, runs like a champ. Gonna invest in a fuel pressure gauge, seems worth it at this point


Sent from my iPhone using Tapatalk

__________________
99 Wrangler Sport 4.0 Auto - 4.10 gearing
3.5" lift - 33X12.50/18
Currie currectlync and front track bar
Redhead steering box - Cervinis cowl hood
doubleDIN center mod w rear seat 10" sub mod
bed tred carpet w raptorlined dash/plastic
n0useforaname is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 05:27 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC