SpeedoHealer-Issues and Cracked - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Like Tree3Likes
  • 1 Post By loukaps
  • 1 Post By Gottagofast
  • 1 Post By explorerlyon
Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-15-2019, 10:23 PM
Thread Starter
  #1
Newb
 
Join Date: Aug 2009
Location: SoCal
Posts: 13
SpeedoHealer-Issues and Cracked

I have had this SpeedoHealer installed since about 2010. Mounted to the firewall next to the ECU. My guess is heat has caused the cracks and the unit to fail. Anyone else see this before? Where have you mounted yours to prevent too much heat? The cables were mounted secure and zip tied to relieve any strain or pulling on the unit as well.

Suggestions for mounting the next one?

Attached Thumbnails
Click image for larger version

Name:	20190515_210250_resized.jpg
Views:	11
Size:	212.4 KB
ID:	4150459   Click image for larger version

Name:	20190515_210335_resized.jpg
Views:	11
Size:	209.1 KB
ID:	4150461  

Click image for larger version

Name:	20190515_210314_resized.jpg
Views:	11
Size:	221.9 KB
ID:	4150463  
explorerlyon is offline   Quote
Old 05-15-2019, 10:58 PM   #2
Jeeper
 
Gottagofast's Avatar
 
Join Date: May 2017
Posts: 6,707
Personally, I'd just get the correct speedo gear for $30

Gottagofast is offline   Quote
Old 05-15-2019, 11:45 PM   #3
Newb
 
Join Date: May 2016
Posts: 4
Quote:
Originally Posted by Gottagofast View Post
Personally, I'd just get the correct speedo gear for $30
Have you never heard of a super short sye?
Laggy likes this.
loukaps is offline   Quote
Sponsored Links
Advertisement
 
Old 05-16-2019, 12:27 AM   #4
Jeeper
 
Gottagofast's Avatar
 
Join Date: May 2017
Posts: 6,707
Quote:
Originally Posted by loukaps View Post
Have you never heard of a super short sye?
Sure have.... who knows, maybe the op even has one but it hasn't been mentioned yet.....

Maybe your next post will be more helpful and less confrontational...
jeepers29 likes this.
Gottagofast is offline   Quote
Old 05-16-2019, 08:56 AM
Thread Starter
  #5
Newb
 
Join Date: Aug 2009
Location: SoCal
Posts: 13
Quote:
Originally Posted by Gottagofast View Post
Personally, I'd just get the correct speedo gear for $30
The Rubicon 42RLE does not have a speedo gear. That is why so many use the SeedoHealer.
explorerlyon is offline   Quote
Old 05-16-2019, 09:15 AM   #6
Jeeper
 
Gottagofast's Avatar
 
Join Date: May 2017
Posts: 6,707
Yep and maybe he has one of those... we don't know that either
Gottagofast is offline   Quote
Old 05-16-2019, 10:58 AM   #7
Jeeper
 
tworley's Avatar
 
Join Date: Jun 2014
Location: Morrison, CO
Posts: 4,379
Ive seen one mounted in the glovebox before. From what I remember the wires are fairly long.



Mine is located driver-side on a wiring harness and is held up by zipties.


Does it still function?
__________________
97' 4.0L - AX-15 - 4.56 D30/Rubi44 - 4" SL -1.25" BL - 1" MML - 35s - XRC Rear Bumper/Carrier - JB SSYE - MC F/R CAs - MC F/R TBs - Currie Currectlync - Currie AR - Savvy GTS - Savvy UA - Savvy Shift Cable - ARB RD100/116 - Alloy/RG&A Axle Shafts - Currie Mini Skids - Superwinch LP8500 - Poison Spyder Rocker Knockers - Poison Spyder Defender XCs - BMB Brakes
Colorado Jeep
tworley is offline   Quote
Old 05-16-2019, 11:41 AM
Thread Starter
  #8
Newb
 
Join Date: Aug 2009
Location: SoCal
Posts: 13
Quote:
Originally Posted by tworley View Post
Ive seen one mounted in the glovebox before. From what I remember the wires are fairly long.



Mine is located driver-side on a wiring harness and is held up by zipties.


Does it still function?
It does not function properly. The speedo would drop to zero for a while than bounce back up then drop to zero. I like the device, it has great reviews and I have never seen anyone in the forums (this or others) report any problem with the speedohealer. I will buy another one, just maybe mount it somewhere than the firewall.
__________________
05 Rubicon Unlimited, Automatic
explorerlyon is offline   Quote
Old 05-16-2019, 11:42 AM
Thread Starter
  #9
Newb
 
Join Date: Aug 2009
Location: SoCal
Posts: 13
Quote:
Originally Posted by Gottagofast View Post
Yep and maybe he has one of those... we don't know that either
I do have one of those and its in my profile. Hence, why I have a speedohealer instead of just changing the gear.
poolguy62 likes this.
__________________
05 Rubicon Unlimited, Automatic
explorerlyon is offline   Quote
Old 05-16-2019, 01:04 PM   #10
Jeeper
 
agalloch07's Avatar
 
Join Date: Aug 2016
Posts: 3,049
How do you set that if it's mounted under the hood? That thing is really weird looking the way it swelled and split open like that. I recently installed a Dakota Digital SGI-5E and mounted it under the dash.
__________________
94, 4.0/NV4500/NP231HD w/JB Conversions super short SYE, 4.5" Rubicon Express lift, JKS 1.25" body lift, Dana 489's w/OX lockers 4.88 gears, Tom Woods drveshafts, 35" BFG KM3's, WFO boomerang shackles, Warn XD9000 winch, Doug Thorley header, JBA mid pipe, Borla cat back.
agalloch07 is offline   Quote
Old 05-16-2019, 01:22 PM
Thread Starter
  #11
Newb
 
Join Date: Aug 2009
Location: SoCal
Posts: 13
Quote:
Originally Posted by agalloch07 View Post
How do you set that if it's mounted under the hood? That thing is really weird looking the way it swelled and split open like that. I recently installed a Dakota Digital SGI-5E and mounted it under the dash.
Very easy to set, even when mounted under the hood. I originally set it loose, then stuck it to the firewall. Basically once set, no need to ever touch it again. I wondered if it maybe split open by getting a little moisture into the unit that froze. Who knows. These are great units and I never hear of any issues with them.
__________________
05 Rubicon Unlimited, Automatic
explorerlyon is offline   Quote
Old 05-16-2019, 01:58 PM   #12
Jeeper
 
tworley's Avatar
 
Join Date: Jun 2014
Location: Morrison, CO
Posts: 4,379
Quote:
Originally Posted by explorerlyon View Post
It does not function properly. The speedo would drop to zero for a while than bounce back up then drop to zero. I like the device, it has great reviews and I have never seen anyone in the forums (this or others) report any problem with the speedohealer. I will buy another one, just maybe mount it somewhere than the firewall.

The symptoms you describe sound like the sensor itself is bad, not the box (tone ring loose or just a faulty sensor (it is 10 years old)). Though I have never seen the box itself fall apart like yours. I'd call Blue Monkey and see what they suggest, maybe they can warranty it for you.
__________________
97' 4.0L - AX-15 - 4.56 D30/Rubi44 - 4" SL -1.25" BL - 1" MML - 35s - XRC Rear Bumper/Carrier - JB SSYE - MC F/R CAs - MC F/R TBs - Currie Currectlync - Currie AR - Savvy GTS - Savvy UA - Savvy Shift Cable - ARB RD100/116 - Alloy/RG&A Axle Shafts - Currie Mini Skids - Superwinch LP8500 - Poison Spyder Rocker Knockers - Poison Spyder Defender XCs - BMB Brakes
Colorado Jeep
tworley is offline   Quote
Old 05-16-2019, 02:19 PM   #13
Jeeper
 
Apparition's Avatar
 
Join Date: Jul 2016
Location: Minnesota
Posts: 265
I stuck mine on the ECU but the heat made the Velcro adhesive loosen. I have mine stuck on the fire wall near the ECU now. No issues so far.
Apparition is offline   Quote
Old 05-16-2019, 06:32 PM   #14
Jeeper
 
Gottagofast's Avatar
 
Join Date: May 2017
Posts: 6,707
Quote:
Originally Posted by explorerlyon View Post
I do have one of those and its in my profile. Hence, why I have a speedohealer instead of just changing the gear.
I see you put it in your sig now.... good move....
Much better than expecting everyone to dig through your profile to find out what ur running....

Personally in that case I would contact the manufacturer before buying another one... I'd say there's a fair chance they'd send you another one free or at least at a discount...
It's at least worth asking and might save you a fair chunk of money....
I'd probably mount it under the dash beside or behind the fuse box....
Gottagofast is offline   Quote
Old 05-16-2019, 09:55 PM   #15
Jeeper
 
chevymad's Avatar
 
Join Date: Jul 2012
Location: Skamokawa, WA
Posts: 634
My velcro came loose and the box landed on the exhaust and melted. Still works. Not sure why yours is splitting like that.
chevymad is offline   Quote
Old 05-17-2019, 04:46 AM   #16
Jeeper
 
Laggy's Avatar
 
Join Date: Sep 2014
Posts: 3,242
Quote:
Originally Posted by explorerlyon View Post
I have had this SpeedoHealer installed since about 2010. Mounted to the firewall next to the ECU. My guess is heat has caused the cracks and the unit to fail. Anyone else see this before? Where have you mounted yours to prevent too much heat? The cables were mounted secure and zip tied to relieve any strain or pulling on the unit as well.

Suggestions for mounting the next one?
I have mine run forward, up firewall, into the cab, sits perfectly velcroed to carpet just in front of my shifter. Basically under middle controls bezel. Little toasty but nothing like engine bay. Call Blue Monkey, I bet they'll replace for a small fee.

Hopefully you can get a new one.

And yes I have a super short sye, so no mas gear!
__________________
Laggy's 97 Build Thread

Here it is standing: atoms with consciousness; matter with curiosity. Stands at the sea, wonders at wondering: I, a universe of atoms an atom in the universe. - Richard Feynman
Laggy is offline   Quote
Old 05-17-2019, 10:02 AM
Thread Starter
  #17
Newb
 
Join Date: Aug 2009
Location: SoCal
Posts: 13
UPDATE: I sent pictures to both Blue Monkey (distributor) and to HealTech (manufacturer). Neither have seen this before. My other theory is maybe some moisture got inside the device and froze cracking the case. I ordered another one, this is not a warranty item.
__________________
05 Rubicon Unlimited, Automatic
explorerlyon is offline   Quote
Old 05-17-2019, 02:34 PM   #18
Jeeper
 
Gottagofast's Avatar
 
Join Date: May 2017
Posts: 6,707
That's a shame.... they could have at least discounted it for you.....

Gottagofast is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Idle issues and i think a cracked intake manifold Pk2000wrangler TJ Tech Forum 5 01-10-2017 08:50 AM
Speedohealer plug and play? Newbie03rubi TJ General Discussion Forum 4 03-11-2015 07:23 AM
cracked exhaust manifold issues need advice akousticman TJ Tech Forum 2 06-04-2013 10:53 AM
Cracked Windshield Issues? IsaacTJ TJ General Discussion Forum 7 11-01-2011 05:49 AM
Check out the SpeedoHealer @ Jeep Safari in Moab!!!! BlueMonkeyMoto Vendor Spotlight! Great Deals for Members. 0 02-26-2011 07:18 PM





All times are GMT -5. The time now is 06:19 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC