Trouble shooting advice on an electrical issue - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Like Tree2Likes
  • 1 Post By Digger84
  • 1 Post By SN95GT50
Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-25-2020, 03:34 PM
Thread Starter
  #1
Jeeper
 
Join Date: Dec 2012
Location: Green Bay, WI
Posts: 334
Trouble shooting advice on an electrical issue

I have a problem where I turn the signal light on and off. After I shut it off or it automatically shuts off, although the light no longer flashes on the dash, I can still hear it signaling. Sometimes it is the hazard lights that are then flashing. Odd. If I flip it on and then off again, I can get ti to stop flashing and annoying other drivers. It usually only happens when I signal left, not right.

I did replace the signal light lever but that didn't help. In fact, it seemed that the wire plug didn't snap on tightly and I had to push hard to get it to work. But now that it is all assembled together, perhaps it is loose again? Perhaps it was replaced once before and the wire plug clip broke and so it isn't staying on firmly?

I hope I'm being clear. Any thoughts or ideas? It is a 1999 TJ sport.

Thanks.
Joe

Hazlitt777 is offline   Quote
Old 01-25-2020, 04:25 PM   #2
Jeeper
 
Join Date: Apr 2013
Posts: 13,253
Sounds like multifunction switch and the aftermarket ones are junk


Sent from my iPhone using Tapatalk
Hazlitt777 likes this.

Digger84 is offline   Quote
Old 01-25-2020, 11:19 PM
Thread Starter
  #3
Jeeper
 
Join Date: Dec 2012
Location: Green Bay, WI
Posts: 334
Quote:
Originally Posted by Digger84 View Post
Sounds like multifunction switch and the aftermarket ones are junk


Sent from my iPhone using Tapatalk
So your saying I should order from Jeep direct?
Hazlitt777 is offline   Quote
Sponsored Links
Advertisement
 
Old 01-25-2020, 11:23 PM   #4
Jeeper
 
Join Date: Apr 2013
Posts: 13,253
On my 98 TJ I got one from an XJ at junkyard after having a bad experience with a lifetime aftermarket one
Hardtops that are not removable get a lot less water exposure from rain ect


Sent from my iPhone using Tapatalk
Digger84 is offline   Quote
Old 02-01-2020, 06:37 AM   #5
Jeeper
 
SN95GT50's Avatar
 
Join Date: Aug 2014
Location: Waukee, IA
Posts: 788
I just put the factory multifunction back in after replacing it with a NAPA one, to get the driving light option. Go OEM, aftermarket are unreliable is my experience.

Sent from my SM-G960U using Tapatalk
Hazlitt777 likes this.
__________________
2005 Wrangler X, 4.0L, 6 Speed
Zone 3" Lift - SYE Eliminator Tom Woods DS
Ford 8.8 rear, Dana 30 HP - 4.10 gears
Barricade HD Trailforce front bumper -made into a stubby
Home built rear bumper/tire carrier
SN95GT50 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 04:20 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.