4.0 tapping noise - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-06-2018, 11:41 AM
Thread Starter
  #1
Jeeper
 
Join Date: Jul 2016
Location: South Florida
Posts: 75
4.0 tapping noise

My 4.0 has always had this distinct tapping sound once warm, but after I did an oil change it got louder. The tapping sound is not piston slap, not a rod knock. It sounds more like a noisy lifter but it's a little different. I'll try to upload a video of the noise but I doubt the camera will pick up the sound loud enough to hear clearly. Any other sources for tapping noises? It gets quicker as rpm go up but goes away after a certain rpm

It's not an exhaust manifold leak because I had it changed to the better design and I checked all around it already for cracks. Maybe my muffler or something?

Kbh7607 is offline   Quote
Old 07-06-2018, 04:44 PM   #2
Jeeper
 
283 YJ's Avatar
 
Join Date: Aug 2017
Location: Central Oregon
Posts: 421
What sort of oil pressure are you getting? Could be a sticking lifter. In the old days, just after the horse and buggy, I would run a quart of ATF in the engine. If it's a sticky lifter, that'll clean it. But there are "purge" products on the market to use as a cleaning agent prior to an oil change. Might give that a try.

Also, any chance it's a timing chain?

__________________
If I ever ask you if you want me to be honest with you, say no.
283 YJ is offline   Quote
Old 07-06-2018, 11:07 PM
Thread Starter
  #3
Jeeper
 
Join Date: Jul 2016
Location: South Florida
Posts: 75
Quote:
Originally Posted by 283 YJ View Post
What sort of oil pressure are you getting? Could be a sticking lifter. In the old days, just after the horse and buggy, I would run a quart of ATF in the engine. If it's a sticky lifter, that'll clean it. But there are "purge" products on the market to use as a cleaning agent prior to an oil change. Might give that a try.

Also, any chance it's a timing chain?
My oil pressure is very normal. Never drops below 20 at idle and never gets too high at highway speeds.

Here's an update; I drove almost 100 miles today, and about 60 of those miles were highway miles at around 65-70 MPH.

The tapping sound is not nearly as loud as before anymore. Maybe the oil level went down a bit and helped? I have a pretty decent oil leak from God knows where and I have to add oil every few weeks. Would adding additives right now when the oil is a little low be fine? I just did an oil change a few days ago
Kbh7607 is offline   Quote
Sponsored Links
Advertisement
 
Old 07-06-2018, 11:20 PM   #4
IRQ
Jeeper
 
IRQ's Avatar
 
Join Date: Dec 2014
Location: NY
Posts: 2,144
With out hearing the sound it's hard to give any input, but I will give you an example of something that happened to me recently.

About a month ago I started to hear some odd engine noise, the noise was pinging/detonation and it was resolved with higher octane fuel, and adding can of BG 44k to the fuel.

The symptoms were obviously the noise, higher engine temps, and a sluggish feeling.

Here is the best video I have found that reproduces the sound
__________________
1995 Rio Grande • 2.5L • AX-5 • 50,000 miles • Stock
IRQ is online now   Quote
Old 07-07-2018, 10:55 PM
Thread Starter
  #5
Jeeper
 
Join Date: Jul 2016
Location: South Florida
Posts: 75
Quote:
Originally Posted by IRQ View Post
With out hearing the sound it's hard to give any input, but I will give you an example of something that happened to me recently.

About a month ago I started to hear some odd engine noise, the noise was pinging/detonation and it was resolved with higher octane fuel, and adding can of BG 44k to the fuel.

The symptoms were obviously the noise, higher engine temps, and a sluggish feeling.

Here is the best video I have found that reproduces the sound
I found a few YouTube videos that match my sound. It's the timing chain. I only have 108k miles, why would my timing chain be making noise already? How long can I drive it without causing damage?
Kbh7607 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 10:32 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.