Shutdown on the Road: - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-18-2019, 10:35 PM
Thread Starter
  #1
Jeeper
 
Defcon 1's Avatar
 
Join Date: Jun 2012
Location: South New Jersey
Posts: 1,192
Shutdown on the Road:

I have something weird going on with my fuel system, '91 2.5L MPFI. I was driving on the road for around 30 minutes and then the engine cut off with no acceleration, power remained on. I tried jimmy-starting it back up while at speed in 3rd gear, no help. I was able to coast for about a minute until I found a safe place to brake and pull over. Also to note, the engine experienced a temporary overheat above 210' (it got around 230') while I was coasting to the shoulder, not sure what that's about. Maybe it had something to do with me being in gear and turning the motor over mechanically while it was physically off?

Back in the garage, I measured 12.9V on the battery, (a little low probably because I had my flashers on for an hour+ waiting for a tow home).

When I got a fuel gauge on the rail, the immediate pressure reading was 0psi. I then went to key-on and it remained at 0psi. Just to troubleshoot a bit further, I went to key-off, then I swapped the ASD and Fuel Pump relays. I went to key-on and it shot right up to 35psi.

But relays generally don't go bad, so after going key-off, I reinstalled the the ASD and FP relay back in their original position, and went to key-on, it went back to 35psi. So now I'm leaning towards maybe an intermittent FP issue?

Also another thing which I don't think is normal, when I kept going from key-on to key-off to get the fuel rail to prime, sometimes the fuel held at 30 psi, and sometimes within 5 minutes it leaked down to around 10 psi. Not sure what that is about, is there a check valve on the rail that could be partially open?

Might have a couple problems going on at the same time, any thoughts?

__________________
1991 YJ / MPFI 2.5L / AX-5 / Non-CAD D-30 / D-35 / 4.10's / 1" MML / 1" BL / 32x11.50R15 BFG MT-KM2 (See Jeep-Profile for Detailed List of Upgrades / Mods)

Past Project: Rear Shackle Frame-Rot Repair
Defcon 1 is offline   Quote
Old 08-19-2019, 08:26 AM   #2
Jeeper
 
Gottagofast's Avatar
 
Join Date: May 2017
Posts: 8,091
230* after shut doen is a non issue...

Probably have either a bad fuel pump or a poor connection in the relay socket... you'll need to drive it more and keep testing till the problem shows up again

__________________
I come in peace.... I mean you no harm
Currently in the stable: ... 97 tj 4.0 5 speed stock....04 tj 4.0 auto 4" and 33's... 98 tj roller for future build... 94 yj sahara 4.5" RE and 33's... 92 yj sbc 3/4 ton axles and 38's... Cj5,7,yj,xj,ex mud dragster project

TJ dash speakers that actually rock! Kicker sub and amp in center console
Gottagofast is offline   Quote
Old 08-19-2019, 10:13 AM
Thread Starter
  #3
Jeeper
 
Defcon 1's Avatar
 
Join Date: Jun 2012
Location: South New Jersey
Posts: 1,192
Quote:
Originally Posted by Gottagofast View Post
230* after shut doen is a non issue...

Probably have either a bad fuel pump or a poor connection in the relay socket... you'll need to drive it more and keep testing till the problem shows up again
Ok good I wasn't sure why the temp got up past the thermostat limit it never goes above 190'-200' and it was weird how it suddely increased and remained at 230' while I was coasting down the road.

I did check the sockets of the fuse box relays and cleaned them with No-Flash contact cleaner. The sockets are tight but I will most likely unsecure the PDC and look underneath to see if I have any pulled or loose wiring from the sockets.

The fuel pump was replaced in 2007 so it might be time, sucks because I had just filled up a few days ago and still have around 16 gallons in the tank 😞

What do you think is up with the fuel pressure drop over time? Or no drop at all?
__________________
1991 YJ / MPFI 2.5L / AX-5 / Non-CAD D-30 / D-35 / 4.10's / 1" MML / 1" BL / 32x11.50R15 BFG MT-KM2 (See Jeep-Profile for Detailed List of Upgrades / Mods)

Past Project: Rear Shackle Frame-Rot Repair
Defcon 1 is offline   Quote
Sponsored Links
Advertisement
 
Old 08-19-2019, 12:22 PM   #4
Moderator

WF Lifetime Member
WF Supporting Member
::WF Moderator::
 
Luckymac's Avatar
 
Join Date: Jan 2014
Location: SouthEast of Denver
Posts: 9,237
One thought on the fuel pressure randomly dropping over time is that there might be a speck of dirt or other crud holding the no-return valve open (if in fact there is actually a non-return valve).
I'm a proponent of Seafoam. I'd try a can of Seafoam in the remaining 16 gallons of gasoline in your tank and attempt to drive around until the fuel is close to used up. If the issue continues, at least the tank will be closer to empty.

You state that relays "generally don't go bad". I agree, up to a point. For the cost of a relay, I'd install a new relay to be certain. If nothing changes, you have a spare.

Keep us posted on your progress.

Good Luck, L.M.
__________________
"Wrangler....It's not just a vehicle, It's a lifestyle".
.................................................. ........................
1987 YJ-4.2L-Standard Shift- Re-manufactured Carter Carb-2" body Lift-31X10.5X15 BFG KOs-190K Miles No back seat.
HEI distributor with computer and all related relays and wiring removed.
12K Badlands winch with dual batteries.
Warn front bumper. Matching imitation Warn bumper on the rear.
Luckymac is offline   Quote
Old 08-19-2019, 12:35 PM
Thread Starter
  #5
Jeeper
 
Defcon 1's Avatar
 
Join Date: Jun 2012
Location: South New Jersey
Posts: 1,192
Quote:
Originally Posted by Luckymac View Post
One thought on the fuel pressure randomly dropping over time is that there might be a speck of dirt or other crud holding the no-return valve open (if in fact there is actually a non-return valve).
I'm a proponent of Seafoam. I'd try a can of Seafoam in the remaining 16 gallons of gasoline in your tank and attempt to drive around until the fuel is close to used up. If the issue continues, at least the tank will be closer to empty.

You state that relays "generally don't go bad". I agree, up to a point. For the cost of a relay, I'd install a new relay to be certain. If nothing changes, you have a spare.

Keep us posted on your progress.

Good Luck, L.M.
Thank you that's good information, I see that valve you mentioned looks like it's real accesable right on the fuel rail. Maybe worth a shot taking it off and cleaning it directly? Looks like it's also vacuum assisted on the one side.

I actually just got back from the garage and transferred all 16 gallons of fuel to gas cans via a fluid transfer pump. But I can do a gas-to-seafoam ratio on a smaller scale instead of the full 16 gallons. I can run it up and down the street I live at the bottom of a hill so if worst comes to worst I can just coast back down to my garage lol.

I agree with you on the relays, couldn't hurt to have a spare. I'm kinda in a tricky spot with this because if it fails again I'm going to be stuck on the road again somewhere. Since the FP is 10+ years old, I'm going to prep on swapping it out as precautionary and start pricing something out. (The tank will be super easy to drop, I just installed all new hardware and hoses from my Shackle-Frame repair project in case my future-self needed to drop the tank again lol).

Going to do some more wiring checks before I drop it though. If I can't find a direct issue that would cause a stall at 50mph, I think the FP would be a good candidate to change for peace of mind sake.
__________________
1991 YJ / MPFI 2.5L / AX-5 / Non-CAD D-30 / D-35 / 4.10's / 1" MML / 1" BL / 32x11.50R15 BFG MT-KM2 (See Jeep-Profile for Detailed List of Upgrades / Mods)

Past Project: Rear Shackle Frame-Rot Repair
Defcon 1 is offline   Quote
Old 08-20-2019, 12:01 AM   #6
Jeeper
 
Gottagofast's Avatar
 
Join Date: May 2017
Posts: 8,091
No the valve is built into the fuel pump...
The thing on the rail is the fpr
__________________
I come in peace.... I mean you no harm
Currently in the stable: ... 97 tj 4.0 5 speed stock....04 tj 4.0 auto 4" and 33's... 98 tj roller for future build... 94 yj sahara 4.5" RE and 33's... 92 yj sbc 3/4 ton axles and 38's... Cj5,7,yj,xj,ex mud dragster project

TJ dash speakers that actually rock! Kicker sub and amp in center console
Gottagofast is offline   Quote
Old 08-28-2019, 01:12 PM
Thread Starter
  #7
Jeeper
 
Defcon 1's Avatar
 
Join Date: Jun 2012
Location: South New Jersey
Posts: 1,192
Just for follow-up, I was able to (so far) have 2 successful trial runs for 15 and 30 minutes.

- Replaced FP with new Bosch FP / swapped old filter-sock onto new pump
- Reworked FP ground wire with new wire/terminal to a newly grounded frame section with SS hardware, covered outer area with sealant for rust protection.
- Performed inspection on PDC Fuse Terminals for FP & ASD, cleaned as precautionary
- Swapped ASD relay with Starter Relay / Replaced FP Relay with new unit
- Removed and cleaned FPR on fuel rail (many deposits found and removed)
- Cleaned fuel tank completely with solvent and removed all traces of particles inside the tank.
- Performed leak/pressure check on the tank venting lines
- Performed leak/pressure check on main fuel lines / return lines
- Treated fuel system with 1 can of SeaFoam prior to filling tank
- Tested new FP pressure at start-up, around 25-35 PSI with little to no leak back
- Removed and replaced Main Tank-Filling and Main Tank-Venting lines

I think I should be good at this point, won't find out truly until a few long-range test drives lol.
__________________
1991 YJ / MPFI 2.5L / AX-5 / Non-CAD D-30 / D-35 / 4.10's / 1" MML / 1" BL / 32x11.50R15 BFG MT-KM2 (See Jeep-Profile for Detailed List of Upgrades / Mods)

Past Project: Rear Shackle Frame-Rot Repair
Defcon 1 is offline   Quote
Old 08-28-2019, 02:41 PM   #8
Moderator

WF Lifetime Member
WF Supporting Member
::WF Moderator::
 
Luckymac's Avatar
 
Join Date: Jan 2014
Location: SouthEast of Denver
Posts: 9,237
Quote:
Originally Posted by Defcon 1 View Post
Just for follow-up, I was able to (so far) have 2 successful trial runs for 15 and 30 minutes.

- Replaced FP with new Bosch FP / swapped old filter-sock onto new pump
- Reworked FP ground wire with new wire/terminal to a newly grounded frame section with SS hardware, covered outer area with sealant for rust protection.
- Performed inspection on PDC Fuse Terminals for FP & ASD, cleaned as precautionary
- Swapped ASD relay with Starter Relay / Replaced FP Relay with new unit
- Removed and cleaned FPR on fuel rail (many deposits found and removed)
- Cleaned fuel tank completely with solvent and removed all traces of particles inside the tank.
- Performed leak/pressure check on the tank venting lines
- Performed leak/pressure check on main fuel lines / return lines
- Treated fuel system with 1 can of SeaFoam prior to filling tank
- Tested new FP pressure at start-up, around 25-35 PSI with little to no leak back
- Removed and replaced Main Tank-Filling and Main Tank-Venting lines

I think I should be good at this point, won't find out truly until a few long-range test drives lol.
You did a lot of work that may or may not have been necessary. I'd have probably done the same thing. Overkill and no further breakdowns is better than underkill and the possibility of continued breakdowns.

Breakdown always seem to happen miles from cell service (on the trail) or during the worst inclement weather when commuting.

Hope all continues to work well on the longer test drives.

Good Luck, L.M.
__________________
"Wrangler....It's not just a vehicle, It's a lifestyle".
.................................................. ........................
1987 YJ-4.2L-Standard Shift- Re-manufactured Carter Carb-2" body Lift-31X10.5X15 BFG KOs-190K Miles No back seat.
HEI distributor with computer and all related relays and wiring removed.
12K Badlands winch with dual batteries.
Warn front bumper. Matching imitation Warn bumper on the rear.
Luckymac is offline   Quote
Old 08-29-2019, 05:04 AM
Thread Starter
  #9
Jeeper
 
Defcon 1's Avatar
 
Join Date: Jun 2012
Location: South New Jersey
Posts: 1,192
Quote:
Originally Posted by Luckymac View Post
You did a lot of work that may or may not have been necessary. I'd have probably done the same thing. Overkill and no further breakdowns is better than underkill and the possibility of continued breakdowns.

Breakdown always seem to happen miles from cell service (on the trail) or during the worst inclement weather when commuting.

Hope all continues to work well on the longer test drives.

Good Luck, L.M.

Yeah it's definitely overkill, but like you said it's super inconvenient (and sometimes dangerous) to risk a breakdown when you're far away / bad weather / on a trail.

Also I figured I should put as much time into troubleshooting the problem as I have waited for AAA to show up to come get me lol

__________________
1991 YJ / MPFI 2.5L / AX-5 / Non-CAD D-30 / D-35 / 4.10's / 1" MML / 1" BL / 32x11.50R15 BFG MT-KM2 (See Jeep-Profile for Detailed List of Upgrades / Mods)

Past Project: Rear Shackle Frame-Rot Repair
Defcon 1 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 05:58 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.