Starter Solenoid, Coil, Ignition Module repeated failures - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > CJ Jeep Forum > CJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-30-2017, 04:57 PM
Thread Starter
  #1
Newb
 
Join Date: May 2017
Posts: 1
Starter Solenoid, Coil, Ignition Module repeated failures

Unable to determine what is causing (randomly) the starter solenoid, ignition coil, and or the ignition control module to fail necessitating replacement. The components get to hot to touch. Over random periods of time one or more of the mentioned components will fail after the vehicle is turned off. It has not stopped running while traveling, but may fail to start after having been parked for an undetermined period of time. All the wiring has been checked and rechecked for integrity and routing. Some wires replaced due to insulation issues. I checked voltage at the coil and starter solenoid and found it to be steady @ 13.4-13.6V with the engine running. The time required for one or more components to fail varies.

Desperate

cjflyboy is offline   Quote
Old 06-01-2017, 07:40 AM   #2
Jeeper
 
Join Date: Jul 2016
Posts: 26
sounds like the problem is heat related. Could be something as little as the bushing on the distributor shaft is worn and creating excess heat that in turn is frying these components

MrChips is offline   Quote
Old 08-14-2017, 01:14 PM   #3
Jeeper
 
Join Date: Aug 2016
Posts: 26
Is the ignition module grounded happen to me when I first got mine the whole tub was replaced with fiberglass and my module was not touching any metal I experienced the same problems car wouldn't start and the coil would get hot

Sent from my HTC One M9 using Tapatalk
tj2000mods is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 09:37 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC