Help!2012 Sahara not accelerating over 40mph and losing power! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-04-2015, 05:25 PM
Thread Starter
  #1
Newb
 
Join Date: Feb 2015
Posts: 11
Help!2012 Sahara not accelerating over 40mph and losing power!

Hi! I am new to this so I hope you all can help. I have had my 2012 unlimited Saharah for about a month now. It has 18,000 miles and no modifications. On several occasions I have been driving and the check engine light comes on, then I cannot accelerate past 40 mph. I turn off the vehicle and restart it and it runs fine. On one occasion, it went up to 60 mph then lost power. I have taken it into two Jeep dealers and they say they cannot replicate the problem and there are no stored codes. They say nothing's wrong. Have any of you heard of this? I finally was able to purchase my jeep and I am so disheartened 😪 please help, I don't know what to do!

Sahara36 is offline   Quote
Old 02-04-2015, 05:30 PM   #2
Newb
 
fuccimaria's Avatar
 
Join Date: Jan 2015
Location: Niagara Falls, ontario
Posts: 8
I don't know but sounds like transmission? I can tell u... I just purchased a jeep 2014 with 18,000 km and had a defect in the windshield after 5 weeks of owning it... Jeep / chrysler have been very unhelpful and to sum it up, they suck! I was at 21000 km when I reported it and they said "sorry yr 1000 km over, even though yr still in the one year we can't replace it "? It's been 5 weeks? You are right it is very disheartening.
Sorry for your experience

Maria

fuccimaria is offline   Quote
Old 02-04-2015, 06:34 PM   #3
Jeeper
 
Jkuone's Avatar
 
Join Date: Dec 2013
Location: Colorado
Posts: 907
Hmm, kinda sounds like it's going into limp mode. Is it a Auto tranny ?
If so might ask stealership if there are any computer ( flash ) up dates
That need done....
__________________
2013 JKU , JKS 3 1/2" lift, Poison Spyder/ Expedition one bumpers| chromoly axle shafts|
Currie Adj control arms| EVO Sliders| Fuel Wheels/ 37" STT Pros, G2 5:13 Gears, ARB locker rear/ G2 Front axle, ARB Locker, RCV Shafts,Warn Winch| Rockhard skids , synergy tie rod, drag link | Trail Ready Limiting Straps | Currie Antirock front, WTO Hydro Assist Steering, poison spyder fenders, Hyline front fender liners, Fox 2.0 Res Shocks,
Jkuone is offline   Quote
Sponsored Links
Advertisement
 
Old 02-04-2015, 06:49 PM
Thread Starter
  #4
Newb
 
Join Date: Feb 2015
Posts: 11
It is automatic, Theve done updates but continues to happen 😟
Sahara36 is offline   Quote
Old 02-04-2015, 07:01 PM   #5
Jeeper
 
Jkuone's Avatar
 
Join Date: Dec 2013
Location: Colorado
Posts: 907
Is the jeep all stock ? No lift or bigger tires...Oops I see you say no mods. Hmm....
__________________
2013 JKU , JKS 3 1/2" lift, Poison Spyder/ Expedition one bumpers| chromoly axle shafts|
Currie Adj control arms| EVO Sliders| Fuel Wheels/ 37" STT Pros, G2 5:13 Gears, ARB locker rear/ G2 Front axle, ARB Locker, RCV Shafts,Warn Winch| Rockhard skids , synergy tie rod, drag link | Trail Ready Limiting Straps | Currie Antirock front, WTO Hydro Assist Steering, poison spyder fenders, Hyline front fender liners, Fox 2.0 Res Shocks,
Jkuone is offline   Quote
Old 02-04-2015, 07:12 PM   #6
Jeeper
 
Join Date: Nov 2014
Location: Ontario Canada
Posts: 317
Sahara 36, if you had a check engine light on, there will be a history code stored in either the powertrain module or transmission module if its an auto/trans. They are bull shitting you and sounds like there shop can't deal with figuring out electrical intermittants or don't even bother checking for TSBs. I would go else where. I'm an electrical technician in a dealership where we have over 25 mechanics. There are a lot of mechanics now a days who shy away from doing high tech electrical diagnosis. Even where I work there are only a handful of us who deal with these type of concerns. Find another dealer and if it's under warranty make them hold the Jeep till they figure it out for you. They need to get the trouble code that caused your MIL light to come on and then follow the correct diagnostic flow chart for that specific code. Until then everything is just a guess like spinning a gaming wheel. It can be many different components or systems that can cause what your experiencing. Good Luck.
Saxon Steel is offline   Quote
Old 02-04-2015, 08:04 PM
Thread Starter
  #7
Newb
 
Join Date: Feb 2015
Posts: 11
No modifications, all stock. And that's exactly what they are doing! I took it to auto zone with the light still on, took them them the code, they said it was an oil filter code ��
Sahara36 is offline   Quote
Old 02-04-2015, 08:28 PM   #8
Jeeper
 
Join Date: Nov 2014
Location: Ontario Canada
Posts: 317
Quote:
Originally Posted by Sahara36 View Post
No modifications, all stock. And that's exactly what they are doing! I took it to auto zone with the light still on, took them them the code, they said it was an oil filter code ��
I have never heard of a check engine light coming on for an oil filter. On some newer vehicles there is a code that will set in the driver info centre or may turn on a service vehicle warning light but that is not usually the same as a check engine light. I think you need to go back to where you purchased it and tell them they need to deal with it that its unsafe to drive like that. If your on a highway and all of a sudden your Jeep starts slowing down and loosing power that can be dangerous with all the idiots who like to tail gate at 80 or more MPH. If its a 2012 with only 18,000 miles on it that is a dealer problem not yours. Do not let them give you the big story oh we cant duplicate the concern and have no codes to chase, tell them to install a flight recorder device like we do on problem vehicles at our dealership, and it records everything and then they can see the fault information and determine what steps to take in the diagnosis.
Saxon Steel is offline   Quote
Old 02-04-2015, 08:37 PM
Thread Starter
  #9
Newb
 
Join Date: Feb 2015
Posts: 11
Thank you Saxon steel, I'll do that

Sahara36 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 04:24 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.