My Signals, horn, lights don't work - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-07-2013, 04:58 AM
Thread Starter
  #1
Newb
 
jdeharo's Avatar
 
Join Date: Jun 2013
Posts: 1
My Signals, horn, lights don't work

Okay, So what happened was... After I pumped gas, started it up. My windshield wipers were on at full blast, but it was in the off position. My Signals don't work at all. Horn doesn't honk. Luckily my head lights stayed on. I had to take the fuse out for my windshield wipers just so I could drive home.

My brake lights do work. All the lights on the dash still works. It just everything in the steering column that stopped. I refuse to take it into the dealership so they could charge me an arm/leg.

jdeharo is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 01:52 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.