Power side mirrors question - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-23-2015, 06:33 PM
Thread Starter
  #1
Jeeper
 
Join Date: Aug 2015
Location: New York
Posts: 36
Power side mirrors question

Hi all, I realize today my power side mirror on driver side could move horizontal and vertical but the passenger side only move horizontal with the switch. Is this normal??

PonyJeeper is offline   Quote
Old 08-24-2015, 09:23 AM   #2
Jeeper
 
WaltA's Avatar
 
Join Date: Sep 2013
Location: 3rd Planet, Sol system
Posts: 10,168
No.

__________________
Current Jeep:
2014 Wrangler Unlimited Rubicon X
Previous Jeeps:
1999 Cherokee Limited (w/ Up Country)
1987 Wrangler Laredo
[All custom ordered]
WaltA is offline   Quote
Old 09-13-2015, 08:31 PM   #3
Supporting Member

WF Supporting Member
 
Mrpositraction's Avatar
 
Join Date: Mar 2015
Location: Janesville, WI
Posts: 354
Any follow up to this? Both of my mirrors stopped working at some point. Realized they aren't working anymore. Switch lights up when turning light on but does nothing to adjust the mirrors.
__________________
2015 JKU Hard Rock Edition, Mopar 2" Fox Shock Lift, Power Stop Rotors/pads, JW Speaker J Series, Superchips Flashpaq, and much more......
Mrpositraction is offline   Quote
Sponsored Links
Advertisement
 
Old 09-22-2015, 02:54 PM   #4
Jeeper
 
Nevrbnwheeln's Avatar
 
Join Date: Jan 2014
Location: Selma, CA
Posts: 135
My passenger side mirror stopped working sometime in the resent past also...just noticed today. Dealer will have a look see, but not until 9/29.
Please keep us all updated on any solutions you all may have found.
__________________
2015 Tank JKURHR Bunch-o-stuff I bolted on...some stuff I made myself.
Nevrbnwheeln is offline   Quote
Old 10-23-2015, 09:13 AM   #5
Jeeper
 
Join Date: Sep 2015
Location: Hartwell, Ga
Posts: 25
my passenger mirror will not go up and down either. only 700 miles on jeep
alanjb132 is offline   Quote
Old 10-23-2015, 09:22 AM   #6
Jeeper
 
JeeperJake's Avatar
 
Join Date: Jul 2010
Posts: 3,540
at 1500 miles my adjusters continue to function
don't know about 'heat' as there's no fog/ice as of yet
__________________
get in--buckle up--hang on
"soothing agricultural implement/personal servant/Walter Mitty multidimensional access utility device conveniently travels on pavement when necessary and often keeps me warm/cool/dry/soothed as needed."
JeeperJake is offline   Quote
Old 10-23-2015, 09:41 AM   #7
Fear The Post Count
 
houstonpdlt's Avatar
 
Join Date: Sep 2013
Posts: 312
my passenger mirror was having similar problems, turns out the wire plug was not all the way in from last time I had doors off (my bad). all is well now
houstonpdlt is offline   Quote
Old 10-23-2015, 10:15 AM   #8
Guest
 
Join Date: Sep 2012
Location: Port Moody, Canada
Posts: 283
DUDE!!! That's what the re-call is all about.

Get it into the dealership PDQ!!


Name:  jeep  flaming.jpg
Views: 114
Size:  5.8 KB
120369 is offline   Quote
Old 10-23-2015, 10:20 AM   #9
Jeeper
 
ocd_dave's Avatar
 
Join Date: Jan 2014
Posts: 1,678
It might take me 5 years to notice they don't work, I set them when I bought it, and they haven't been moved since. But now my OCD is taking over, I might have to check at lunch time.
__________________
2014 Rubicon X - Granite Crystal Metallic
6 Speed - Dual Tops - Auto Climate Control - MyGIG 430N - 4.10's
ocd_dave is offline   Quote
Old 10-23-2015, 10:50 AM   #10
Supporting Member

WF Supporting Member
 
RoadiJeff's Avatar
 
Join Date: Dec 2012
Location: St. Louis, MO
Posts: 6,891
Quote:
Originally Posted by Johnny Vintage View Post
DUDE!!! That's what the re-call is all about.
Actually, the power mirror recall has to do with the heater for them that can short out and cause a fire. However, if the power mirrors do not work and it is still under warranty then they should take it in and get it fixed for free.

The ones on our 2013 are still working OK, after nearly 3 years and 30,000 miles.

RoadiJeff is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 05:49 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.