4.0 getting harder to start. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-09-2018, 05:56 PM
Thread Starter
  #1
Jeeper
 
RichnSteph's Avatar
 
Join Date: Apr 2018
Location: San Marcos, Texas
Posts: 284
4.0 getting harder to start.

91 renegade, 66,000 miles on it. 4.0, 5 speed. When I got it it was a "bump" on the ignition and it was running. Now it takes 2 seconds or so of cranking to get it to fire up. Only things I've done is run a cycle of injector cleaner through it and run premium fuel. My guess is that the plugs are a little icky. Am going to do plugs, wires, rotor, etc... this weekend.

Anything out of the ordinary that I should be looking at? This is my first Jeep and first 4.0.

RnS

RichnSteph is offline   Quote
Old 04-09-2018, 07:05 PM   #2
Moderator

WF Lifetime Member
WF Supporting Member
::WF Moderator::
 
Luckymac's Avatar
 
Join Date: Jan 2014
Location: SouthEast of Denver
Posts: 9,098
Your battery terminals probably look just fine. Take them off and clean the terminals & posts. Then remove & clean where the (-) cable bolts to the block (or starter on your model). Check the (+) cable for corrosion all along the cable and where it attaches to the Power Control Center.
Reassemble everything with dielectric grease or Vaseline.

You'd be amazed at how many vehicles are hard to start due to a bit of hidden corrosion.

Good Luck, L.M.

__________________
"Wrangler....It's not just a vehicle, It's a lifestyle".
.................................................. ........................
1987 YJ-4.2L-Standard Shift- Re-manufactured Carter Carb-2" body Lift-31X10.5X15 BFG KOs-190K Miles No back seat.
HEI distributor with computer and all related relays and wiring removed.
12K Badlands winch with dual batteries.
Warn front bumper. Matching imitation Warn bumper on the rear.
Luckymac is offline   Quote
Old 04-09-2018, 08:15 PM
Thread Starter
  #3
Jeeper
 
RichnSteph's Avatar
 
Join Date: Apr 2018
Location: San Marcos, Texas
Posts: 284
Thank you LM! To be honest I'd not even considered cleaning the terminals. I'll do that first since it's easy and free.

RnS
RichnSteph is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 01:07 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.