cant pick up any radio channels with my sterio? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-01-2012, 06:30 PM
Thread Starter
  #1
Jeeper
 
1994JeepYJ's Avatar
 
Join Date: May 2012
Location: Long Island NY
Posts: 75
cant pick up any radio channels with my sterio?

hey i installed a jvc stereo into my YJ a while back and everything works fine except the radio part...it wont pick up the majority of stations..i can get one or two occasionally but usually there's nothing on every station. i plugged the antenna into the back of the stereo and it seemed to fit. has anyone else encountered this?

EDIT: just to be clear the same stereo worked great in my other car. so im pretty sure something is wrong with the antenna or antennas connection to the stereo.

1994JeepYJ is offline   Quote
Old 08-01-2012, 06:43 PM   #2
Jeeper
 
jeff_in_rc's Avatar
 
Join Date: Mar 2012
Location: Ridgecrest, CA
Posts: 1,527
Sounds like a bad antenna. I put in a cheep stereo a while ago and it could not pick up anything but static so I got a new antenna and now it works. If you have a car stereo shop they may have an antenna you could use to test your radio.

__________________
2004 RED TJ Rubicon
Member of the Gear Grinders 4WD Club
jeff_in_rc is offline   Quote
Old 08-01-2012, 06:59 PM   #3
Jeeper
 
rollmeover12's Avatar
 
Join Date: Jul 2012
Posts: 20
I have the same problem....I shall find out as well. Thanks
rollmeover12 is offline   Quote
Sponsored Links
Advertisement
 
Old 08-02-2012, 08:18 PM
Thread Starter
  #4
Jeeper
 
1994JeepYJ's Avatar
 
Join Date: May 2012
Location: Long Island NY
Posts: 75
ok i fixed it! i basically i just un-attached the antenna from the radio and then with the radio on fiddled with it until i got it into a spot that worked. lucky for me it stays in that position even when i hit bumps (for now)....if it moves ill have to tape it.
1994JeepYJ is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 11:06 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.