dead spot - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-14-2011, 07:44 PM
Thread Starter
  #1
Newb
 
Join Date: Aug 2011
Location: West Hazleton
Posts: 5
dead spot

i have a 89 2.5....i just recently got it back from my mechanic for problems with it dieseling and a high idle. before i took it in i replaced the EGR and map sensor. while at the garage they replaced the distributor, plugs, cap and wires (all of which were replaced about 5000 miles ago when i put a new engine in). the mechanic also put a hold down over the distributor so it can be adjusted (this i thought was an ingenious idea considering they are non adjustable). it was running good for a day until i took it to the car wash. i hit the firewall and fenders but tried to stay away from the engine and electrical parts. so now it ha NO power and dead spots when accelerating. it is also still dieseling, which may or may not be a result of the car wash. i should also add the emissions light is on. the jeep itself has 70,000 miles on. there is also a strong odor of gas i have noticed. the engine has 5,000. the dieseling was present before the engine change also....so, any help would be greatly appreciated.

Nesene is offline   Quote
Old 08-15-2011, 09:42 PM   #2
Jeeper
 
Join Date: Jun 2011
Location: n.y.
Posts: 144
make sure the inside of your dist. cap is dry. remember your motor is not a pair of jeans. you have to be careful at the the carwash . i am not saying this because i think you are dumb,i am saying this because i have done it. put your hood up on a nice day and let the the sun get to it .

barjeep is offline   Quote
Old 08-15-2011, 10:58 PM
Thread Starter
  #3
Newb
 
Join Date: Aug 2011
Location: West Hazleton
Posts: 5
yeah, i thought about that and the possibility of water being in there. i have not opened up the hood or checked in the cap yet. but its been about a week. i will check under the cap tomorrow.
Nesene is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead spot in accelerator Thracks JK General Discussion Forum 25 03-13-2011 06:37 PM
dead spot Garner TJ Tech Forum 4 11-05-2010 08:44 AM
Its dead, its not dead...its dead, its not dead!!! chrisb0108 TJ Tech Forum 10 09-15-2010 01:16 PM
SPOT Satellite GPS Messenger purchase Kevin Communications and Electronics 0 06-28-2010 02:59 PM
No Dead Pedal in 6 speed birdman JK General Discussion Forum 7 03-24-2008 11:51 AM





All times are GMT -5. The time now is 12:54 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.