does anyone know why i have a specific fuse that keeps blowing? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-07-2011, 08:14 PM
Thread Starter
  #1
Jeeper
 
Shauna's Avatar
 
Join Date: Jun 2011
Location: Beaverton, OR
Posts: 357
does anyone know why i have a specific fuse that keeps blowing?

The "clock" labeled fuse that controls all my dash gages keeps blowing out. Anyone know why?

__________________
2008 JKU Rubicon - 3.8L V6 automatic, 4" lift, 35" Km2 Mud Terrains, 5.13 Yukon Gears, Dana 44 front & rear, XRC bumpers / body armor / fender flares
Shauna is offline   Quote
Old 08-07-2011, 09:14 PM   #2
Newb
 
NJFire422's Avatar
 
Join Date: Aug 2011
Location: NJ
Posts: 12
Could be a wire that is grounding its self somewhere. Had the same issue with aftermarket lights. Traced the lines and found a "bray" or slice in one of the wires from a rub on the frame. LIttle bit of electrical tape and no more fuse issues.

Hope this helps.

__________________
I do not aim with my hand: he who aims with his hand has forgotten the face of his father.
NJFire422 is offline   Quote
Old 08-08-2011, 01:33 AM   #3
2xs
Jeeper

WF Supporting Member
 
2xs's Avatar
 
Join Date: Jun 2011
Location: Santa Rosa, Ca.
Posts: 2,865
disconnect the clock, then re check the circut.

Your clock work before this? my second hand works, but it thinks its been 3:00 for the past 4 years, so....
2xs is offline   Quote
Sponsored Links
Advertisement
 
Old 08-08-2011, 07:29 AM   #4
Jeeper
 
draarong2004's Avatar
 
Join Date: May 2011
Posts: 499
Quote:
Originally Posted by Shauna View Post
The "clock" labeled fuse that controls all my dash gages keeps blowing out. Anyone know why?
put an aftermarket radio in recently? or have one? check the orange wire on the wiring kit.....i'll put money on it thats grounding out...maybe
draarong2004 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting troubles mother one YJ Tech Forum 11 10-22-2015 06:46 AM
Heater Fuse Keeps blowing DsmRacing YJ Tech Forum 16 01-09-2014 06:04 PM
TJ Fuse Blowing! Jeep_VT TJ General Discussion Forum 1 04-05-2011 06:35 PM
1993 Jeep Grand keeps blowing I.O.D Fuse NastyCivic13 General Jeep Discussion 0 01-28-2011 02:52 PM
Code 33 and Blowing my heater fuse...? Nielsen17 YJ Tech Forum 1 01-28-2010 03:44 PM





All times are GMT -5. The time now is 12:49 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.