frustration - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-27-2015, 08:53 PM
Thread Starter
  #1
Newb
 
Join Date: Jul 2015
Posts: 1
frustration

I have a 1987 wrangler YJ with the 2.5L. Ever since I had it, it has cut out on me when accelerating and recently the mileage has dropped from 13 to 9. I have changed the fuel pump, fuel filter, spark plug leads, distributor, and the brain box. Sometimes it will run great but most the time it just blubbers, even at idle. I could sure use some help. Thanks.

stuart92 is offline   Quote
Old 07-27-2015, 09:44 PM   #2
Jeeper
 
Slowstang305's Avatar
 
Join Date: Mar 2014
Location: South Florida
Posts: 1,167
Send a message via AIM to Slowstang305
Throttle body dirty? clogged injectors?

__________________
"Do not go where the path may lead, go instead where there is no path and leave a trail."

Current toy: 2015 Wrangler JKUR
Previous toy: 2015 Wrangler JKU
Previous toy: 2009 Wrangler JKU
Slowstang305 is offline   Quote
Old 07-27-2015, 10:13 PM   #3
Jeeper
 
OldDogNewJeep's Avatar
 
Join Date: Jun 2015
Location: Colorado Springs
Posts: 605
Welcome Stuart,
Try this forum, TJ Tech Forum - Jeep Wrangler Forum
OldDogNewJeep is offline   Quote
Sponsored Links
Advertisement
 
Old 07-28-2015, 11:03 AM   #4
Jeeper
 
J33PCHIK's Avatar
 
Join Date: Jul 2011
Location: NY
Posts: 339
Quote:
Originally Posted by OldDogNewJeep View Post
Welcome Stuart,
Try this forum, TJ Tech Forum - Jeep Wrangler Forum

Wrong forum....he has a YJ.
__________________
Happy Jeepin'!!
J33PCHIK is offline   Quote
Old 07-28-2015, 11:24 AM   #5
Thank you Veterans

5-Year WF Supporting Member
WF Lifetime Member
::WF Moderator::
 
Beastmaster's Avatar
 
Join Date: Aug 2011
Location: The Old Pubelo
Posts: 41,346
Quote:
Originally Posted by OldDogNewJeep View Post
Welcome Stuart,
Try this forum, TJ Tech Forum - Jeep Wrangler Forum
Quote:
Originally Posted by J33PCHIK View Post
Wrong forum....he has a YJ.
Moved to proper forum
Beastmaster is online now   Quote
Old 07-28-2015, 11:27 AM   #6
Jeeper
 
J33PCHIK's Avatar
 
Join Date: Jul 2011
Location: NY
Posts: 339
__________________
Happy Jeepin'!!
J33PCHIK is offline   Quote
Old 08-06-2015, 08:44 PM   #7
Jeeper
 
OldDogNewJeep's Avatar
 
Join Date: Jun 2015
Location: Colorado Springs
Posts: 605
Quote:
Originally Posted by J33PCHIK View Post
Wrong forum....he has a YJ.
Missed it by that much.

OldDogNewJeep is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 07:08 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.