High oil pressure - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum

Join Wrangler Forum Today


Like Tree1Likes
  • 1 Post By agalloch07
Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-02-2019, 09:10 PM
Thread Starter
  #1
Jeeper
 
Corlauv's Avatar
 
Join Date: Dec 2018
Posts: 78
High oil pressure

Hey guys, so my new 1994 yj with the 4.0 manual is showing really high oil pressure at idle but when I speed up it lowers to normal levels. Is this normal or should I be concerned? Yes, the engine burns a little oil and leaks a little but hat should lead to high pressure right?

Corlauv is offline   Quote
Old 08-02-2019, 09:16 PM   #2
Jeeper
 
agalloch07's Avatar
 
Join Date: Aug 2016
Posts: 3,485
The sending units are known for going bad and reading high i would replace the sender and see if it helps
rushwal likes this.

__________________
94, 4.0/NV4500/NP231HD w/JB Conversions super short SYE, 4.5" Rubicon Express lift, JKS 1.25" body lift, Dana 489's w/OX lockers 4.88 gears, Tom Woods drveshafts, 35" BFG KM3's, WFO boomerang shackles, Warn XD9000 winch, Doug Thorley header, JBA mid pipe, Borla cat back.
agalloch07 is offline   Quote
Old 08-02-2019, 10:11 PM
Thread Starter
  #3
Jeeper
 
Corlauv's Avatar
 
Join Date: Dec 2018
Posts: 78
Quote:
Originally Posted by agalloch07 View Post
The sending units are known for going bad and reading high i would replace the sender and see if it helps
Is the sender bad? Like as far as doing its job? Or is it just giving bad readings? I'm okay with bad readings I just want to make sure that's all it is
Corlauv is offline   Quote
Sponsored Links
Advertisement
 
Old 08-02-2019, 10:20 PM   #4
Jeeper
 
agalloch07's Avatar
 
Join Date: Aug 2016
Posts: 3,485
Quote:
Originally Posted by Corlauv View Post
Is the sender bad? Like as far as doing its job? Or is it just giving bad readings? I'm okay with bad readings I just want to make sure that's all it is

It's probably just a bad reading. I have owned several 90's jeeps in the 90's and 2000's with 4.0's and all but one of them had bad senders they just were not made that well.

I had 2 94 YJ's one was black one was white. When my black ones oil pressure started reading really high i swapped the sender off my white one and it read normal. Then my 92 XJ did it and i swapped sender and same thing, bad sender.

I never replaced the sending units i just ignored the gauge and they ran for hundreds of thousands of miles.
__________________
94, 4.0/NV4500/NP231HD w/JB Conversions super short SYE, 4.5" Rubicon Express lift, JKS 1.25" body lift, Dana 489's w/OX lockers 4.88 gears, Tom Woods drveshafts, 35" BFG KM3's, WFO boomerang shackles, Warn XD9000 winch, Doug Thorley header, JBA mid pipe, Borla cat back.
agalloch07 is offline   Quote
Old 08-03-2019, 12:13 PM   #5
Supporting Member

5-Year WF Supporting Member
 
Got it at last's Avatar
 
Join Date: Nov 2016
Location: Phoenix, Az
Posts: 1,698
Depending on the grade of oil you are using, It is not uncommon for the oil pressure to read high and stay high until the oil warms up a little, you should be mostly concerned that you are getting a steady reading regardless of the pressure value, intermittent flatlining could be loose connection, low oil level, clogged pickup or worse yet, failing oil pump
__________________
'89 YJ 4.2 with MC-2150 Carb & HEI, 2-1/2" Magnaflow Exhaust. BA-10, NP231, Adams front Diveshaft, SYE kit, 31x 10.5 x15 BFG KO's, 2 1/2" RE Springs, 1" Body Lift. RS5000x shocks, Hella H-4's, No emissions.

FSM Manuals https://www.dropbox.com/sh/0vfmk6jc5...v7lceZk7a?dl=0
Got it at last is offline   Quote
Old 08-03-2019, 05:09 PM
Thread Starter
  #6
Jeeper
 
Corlauv's Avatar
 
Join Date: Dec 2018
Posts: 78
Okay, thanks, I'll probably just run with what I have, eventually I'm gonna have to fix the oil leaking problem😂, kind of annoying to have to add oil every 1000 miles

Corlauv is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 11:01 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC