Need help! No spark - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-09-2019, 01:33 PM
Thread Starter
  #1
Newb
 
Join Date: Jun 2019
Posts: 5
Need help! No spark

I have a 93 YJ 2.5 manual trans. Recently I started having a no spark situation intermittently. Sometimes I would shut it off, for instance to refuel or something and then it would crank but no start. After trying it a few times it would eventually start. It would do this occasionally and then it got more frequent. Now it's a constant no spark situation. I have changed the coil twice, the crank sensor the cam sensor, fuses, relays, and did some continuity checks on my grounds. I picked up another ECU yesterday from a local guy that sells used jeep parts and when i plugged it in, I no longer have the fuel pump kicking on when i turn the key on and still no spark. So I put my old ECU back in and my fuel pump is working again when the key is turned on. I did some 12v checks and I do have 12v going into the coil. I don't appear to have a signal from the crank sensor though. I have three of these crank sensors that I have swapped out just in case i had a bad one but still no spark. I did 12v and ground checks at the ECU plug that appear to be good. I really don't know what else to do. If any of you can help me out here I would really appreciate it.

Yjnut93 is offline   Quote
Old 06-09-2019, 10:45 PM   #2
Moderator

WF Supporting Member
::WF Moderator::
 
Luckymac's Avatar
 
Join Date: Jan 2014
Location: SouthEast of Denver
Posts: 8,076
Your coil is controlled by your PCM (computer). The coil gets a constant 12v while the key is on. You already know that.
What causes the coil to spark is the PCM opening and closing the ground circuit.
Other posters can tell you how to check the signal from the PCM. I think you'll need a digital multimeter. A test light won't work.

Good Luck, L.M.

__________________
"Wrangler....It's not just a vehicle, It's a lifestyle".
.................................................. ........................
1987 YJ-4.2L-Standard Shift- Re-manufactured Carter Carb-2" body Lift-31X10.5X15 BFG KOs-190K Miles No back seat.
HEI distributor with computer and all related relays and wiring removed.
12K Badlands winch with dual batteries.
Warn front bumper. Matching imitation Warn bumper on the rear.
Luckymac is offline   Quote
Old 06-13-2019, 06:47 PM   #3
Jeeper
 
Join Date: Jan 2019
Location: Round Rock, TX
Posts: 154
Get yourself a test light. One of the old incandescent bulb ones would be ideal. The reason is that the coil ground (grey) will pulse (on/off) faster than what the DVOM will show. Then test each wire of the connector on it's own. This whole test is to determine if the coil has what it needs to work since you don't have spark something isn't right. Based on this we can establish direction.

Take your test light, clamp it to battery ground. Then unplug the coil connector and touch (don't jam the test lead in) the green with orange wire pin. Turn the key on. Does the test light go on? It should go on, then turn off after 3 secs. This is the prime the computer attempts to do for the fuel pump. Also try to start and make sure the light goes on while start.

The next step is to plug the coil connector in and backprobe the grey wire. Move the test light clamp to battery postive. Touch the backprobe and attempt to start the jeep. You should get a flashing light. Here is a youtube vid that shows what i am talking about. About the 9 min time is where he check the ground.
sequel is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 12:36 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC