Need help with my 87 YJ - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-14-2018, 06:53 PM
Thread Starter
  #1
Newb
 
kirknicholas92's Avatar
 
Join Date: May 2018
Posts: 3
Need help with my 87 YJ

I have an issue I’m trying to work out and any advice would be greatly appreciated! So I have a 1987 Jeep Wrangler Yj with the 4.2 258 in-line 6 automatic trans,
I just bought a new rebuilt motor from s&j motors (bone stock)same exact motor and put it in over the weekend everything is perfect I got it all hooked up and filled with break in oil, so I go to crank it (without plugs) for the first time just to roll the starter and prime the engine everything goes well I prime it good so then I hook up distributor and plugs and I’m ready to hear this thing come to life! I turn it over starter does its job it firing correctly I do this for about a minute and it just stops cranking so I’m like what the hell right? Engine is not locked up everything is free starter is brand new and works just fine when you give it 12v straight from battery so I find out my starter solenoid is not closing so I run down buy an new one and hook it up try to crank it and still nothing so I test it off the Jeep on a battery and it works properly I put it back in jeep and hook it up and again nothing! Power is fine good battery just not turning over when I hit ignition. Everything on the Jeep is good it’s all new but for some reason my starter solenoid will not close or work properly when I have it hooked up to provide power to starter. Please help! Has anyone ever heard of this problem in a late model wrangler?

kirknicholas92 is offline   Quote
Old 05-14-2018, 08:43 PM   #2
Jeeper
 
283 YJ's Avatar
 
Join Date: Aug 2017
Location: Central Oregon
Posts: 416
First problem you're facing is that you're not using punctuation in your post. Hard as hell to figure out what you're trying to say!!!!
After sorting through it, could your battery be the issue? Even a weak battery will spin an unloaded starter. Check that first - cables too.

283 YJ is offline   Quote
Old 05-15-2018, 06:02 AM
Thread Starter
  #3
Newb
 
kirknicholas92's Avatar
 
Join Date: May 2018
Posts: 3
Sorry your having a hard time reading this... battery is just fine as well as cables. Like I said, everything is new and has been tested multiple times. This is an issue that has to go deeper than that, it’s throwing me off because everything was working just fine, then it just stopped.
kirknicholas92 is offline   Quote
Sponsored Links
Advertisement
 
Old 05-15-2018, 09:05 AM   #4
Supporting Member

5-Year WF Supporting Member
 
MannyN's Avatar
 
Join Date: Aug 2017
Location: Sun City CA
Posts: 451
Check your engine ground. If it works on the battery, it should work on the engine.
MannyN is offline   Quote
Old 05-15-2018, 11:17 AM
Thread Starter
  #5
Newb
 
kirknicholas92's Avatar
 
Join Date: May 2018
Posts: 3
Yeah, I’m definitely going to have to meticulously go through my grounds. Hopefully, I can find it there. I’m also going to fool around with my ignition switch and wiring.
kirknicholas92 is offline   Quote
Old 05-15-2018, 01:14 PM   #6
Jeeper
 
283 YJ's Avatar
 
Join Date: Aug 2017
Location: Central Oregon
Posts: 416
You can eliminate a lot of wiring by taking a jumper cable and VERY CAREFULLY
jumping from the pos terminal on the battery to the solenoid and the starter. That should help diagnose a multitude of issues. Jumper can also be used as a ground by going from neg bat terminal to engine block.

283 YJ is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 01:07 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.