New Jeeper Questions - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-15-2011, 02:13 PM
Thread Starter
  #1
Jeeper
 
Join Date: Jul 2011
Posts: 120
New Jeeper Questions

I just got my first jeep last week. I bought a 1995 Wrangler 4.0 lifted already. I have noticed a few things that I wanted help with.

1. Oil leak (may be coming from the rear main seal). Oil leaking on the exhaust pipe. Engine is really oily and plan on cleaning with degreaser. i did notice some oil coming up from around the plate that covers the hole in the floor where the shifter is.

2. When I shift it into 4wd there is no light that comes on to tell me it is in 4wd. I have checked and the shaft is turning in the transfer case.

3. Previous owner must have loved to use zip ties because the power steering reservior is zip tied one and the dist cap is also zip tied on. Plan on replacing them as well.

4. I noticed also that it idles kind of high. Not a first but after driving and pushing on the gas pedal it seems to idle high between 1000 - 2000 rpms.

If anyone can suggest anything I would greatly appreciate it.

yellowlabs is offline   Quote
Old 07-15-2011, 02:53 PM   #2
Jeeper

WF Supporting Member
 
crafty's Avatar
 
Join Date: Dec 2006
Location: Clearwater, FL
Posts: 1,670
1. Rear main leak is very common. Oil around that plate is odd, previous owner might have played in deep oily water areas.

2. Bulb could be out if you are sure the 4wd is working.

3. Zip ties, can be your friend to get off the trail but then fixed soon after.

4. Still think this jeep was in some mud, your throttle cable should slide in and out of a plastic sleeve. Could have gunk in there keeping the throttle high.

__________________
Female rolling with the 93 YJ SOA Locked and Hard at Play
crafty is offline   Quote
Old 07-15-2011, 02:55 PM   #3
Jeeper

WF Supporting Member
 
crafty's Avatar
 
Join Date: Dec 2006
Location: Clearwater, FL
Posts: 1,670
Vacuum leaks could also be the cause of your 4wd light being out if you find your 4wd isn't working. And same type of leak in another area could cause the high rpms also.

Welcome to the site btw :-)
__________________
Female rolling with the 93 YJ SOA Locked and Hard at Play
crafty is offline   Quote
Sponsored Links
Advertisement
 
Old 07-15-2011, 02:56 PM
Thread Starter
  #4
Jeeper
 
Join Date: Jul 2011
Posts: 120
Those are some of my same thoughts as well. I plan on cleaning it throughly and see what I can find. How hard is it to replace the throttle cable or is it easy to clean.
yellowlabs is offline   Quote
Old 07-15-2011, 03:01 PM   #5
Jeeper

WF Supporting Member
 
crafty's Avatar
 
Join Date: Dec 2006
Location: Clearwater, FL
Posts: 1,670
Easy to clean throttle cable. Unhook from throttle body and spray some degreaser into the plastic sleeve while moving the cable. It could also have some cracks in it from age and if thats it you trim it back a little. Not too hard to replace if you decide to do it.
__________________
Female rolling with the 93 YJ SOA Locked and Hard at Play
crafty is offline   Quote
Old 07-15-2011, 03:15 PM
Thread Starter
  #6
Jeeper
 
Join Date: Jul 2011
Posts: 120
I was thinking it could have been a leak also but it seemed to pull when i put it in 4wd low.
yellowlabs is offline   Quote
Old 07-15-2011, 03:42 PM   #7
Jeeper

WF Supporting Member
 
crafty's Avatar
 
Join Date: Dec 2006
Location: Clearwater, FL
Posts: 1,670
4wd low 1st gear your vehicle will crawl. Is it doing that?
__________________
Female rolling with the 93 YJ SOA Locked and Hard at Play
crafty is offline   Quote
Old 07-15-2011, 04:00 PM
Thread Starter
  #8
Jeeper
 
Join Date: Jul 2011
Posts: 120
yea it is..i can even shift into 2nd and it still pulls
yellowlabs is offline   Quote
Old 07-15-2011, 04:17 PM   #9
Jeeper
 
banks316's Avatar
 
Join Date: Apr 2011
Location: Kelso, WA
Posts: 2,096
Possible that you might not have a desconnted front axle. It's common to use xj axles so you do.t have to worry if your front end will lock up or not. In that case your 4wd light will not come on.

Another thing in the throttle body there's a Allen head set screw on that acts as a stopper for the butterfly valve. It's on the opposite side of the throttle cable. This can be moved in and out to adjust idle. Do this if cleaning the throttle body don't help.
__________________
93 YJ I6 5spd
My YJ Build +1.5 inch SOA ,37 12.50 15R Swamper M16's, 5.22:1/2.97:1 Stak Tcase with 92 Crawl Ratio--------SOLD...
banks316 is offline   Quote
Old 07-15-2011, 04:20 PM   #10
Jeeper

WF Supporting Member
 
crafty's Avatar
 
Join Date: Dec 2006
Location: Clearwater, FL
Posts: 1,670
Could even have a posi-loc or a TJ shaft on the passenger side.

If it works I wouldn't sweat the light unless you are having inspection issues.
__________________
Female rolling with the 93 YJ SOA Locked and Hard at Play
crafty is offline   Quote
Old 07-15-2011, 05:21 PM
Thread Starter
  #11
Jeeper
 
Join Date: Jul 2011
Posts: 120
In regards to the oil leak it must be a big one. just went out and check and it had leaked

yellowlabs is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New owner With questions about 2011 Jeep Wrangler Sport Stock! jeep2011mass WF New Member Check In 43 07-19-2011 06:43 PM
Newbie Jeeper Snow, Ice, Wheeling & Tire Questions sdgmcdon JK General Discussion Forum 24 10-15-2010 03:35 PM
New Jeeper here with a few questions poppop TJ General Discussion Forum 5 06-13-2010 10:11 PM
New Member and some newbie questions SlowSpyder TJ General Discussion Forum 8 10-11-2009 10:43 PM
I Got One! Newbie Questions dak_quak JK General Discussion Forum 3 06-04-2009 11:00 AM





All times are GMT -5. The time now is 12:32 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.