no power on highways - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-31-2013, 10:05 AM
Thread Starter
  #1
Jeeper
 
wildbill72's Avatar
 
Join Date: Dec 2013
Posts: 47
no power on highways

yj has manual transmission and has awsome power around town. When I get on interstate top speed is 55 mph and I have to downahift to keep up. The weird thing is that w My 94 hen I down shift to 4th gear the rpms still are below 2000. Any suggestions where I should start.

wildbill72 is offline   Quote
Old 12-31-2013, 11:31 AM   #2
Supporting Member

5-Year WF Supporting Member
 
jokerchief462's Avatar
 
Join Date: Apr 2012
Location: North Las Vegas
Posts: 10,093
Send a message via AIM to jokerchief462
If you got a 6 cylinder you have issues with the motor or a clogged CAT. Bang in the CAT with a rubber mallet and if you hear a bunch if stuff floating around in there get a new one

If you got a four banger lifted you should still see 70 mph on the flat.

__________________
89 2.5 TBI, 4" RC lift, 1" Booms, SYE, Adams Driveshafts front and rear, Ford 8.8 with 4:88s, BFG 33X12.50X15, and a ton of other stuff.

AF Jeep Club Tail Number 184
jokerchief462 is offline   Quote
Old 12-31-2013, 01:22 PM   #3
Jeeper
 
87 Florida YJ's Avatar
 
Join Date: May 2013
Posts: 742
X2 on the clogged cat
__________________
Driving a jeep with a top is like screwing wearing a prophylactic. Maybe a little safer but doesn't feel nearly as good.
87 Florida YJ is offline   Quote
Sponsored Links
Advertisement
 
Old 12-31-2013, 01:44 PM   #4
Jeeper
 
InvictusDecretum's Avatar
 
Join Date: Jul 2013
Location: Hurlburt Field
Posts: 701
x3... clogged cat.

Tribal counsel has spoken.
__________________
'05 Unlimited Rubicon Sahara #268 of 1000
"This baby’s pulse is pumping 4.0 liters of uncensored raw fuel through her straight six nuclear power plant."
My Build Thread: https://www.wranglerforum.com/f322/in...ml#post6709282
InvictusDecretum is offline   Quote
Old 12-31-2013, 04:09 PM
Thread Starter
  #5
Jeeper
 
wildbill72's Avatar
 
Join Date: Dec 2013
Posts: 47
Thanks to all.
wildbill72 is offline   Quote
Old 12-31-2013, 04:32 PM
Thread Starter
  #6
Jeeper
 
wildbill72's Avatar
 
Join Date: Dec 2013
Posts: 47
Also I forgot to mention that the only trouble codes showing are ac clutch relay which has been removed. There has also been a nasty smell in the cab and hard to describe. Mix of burnt oil or gas.

wildbill72 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 10:42 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC