Power steering shenanigans - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-29-2014, 07:25 PM
Thread Starter
  #1
Jeeper
 
WellsR's Avatar
 
Join Date: Aug 2010
Location: New York
Posts: 625
Power steering shenanigans

So Ive looked and looked but cant find just a simple solution to this.

I have a 92 with a 2.5l with a/c and p/s. And my original motor threw a rod a while back. So about 2 weeks ago I got a new motor and trans and swapped it all in. Everything went smooth except for the power steering mounting brackets. They were completely different the way they mounted. So in every thread Ive looked at there was no just do this real quick and it works solution it almost looks like in 95 they were getting ready for the tj(or something along those lines) and some motors have the same mount my 92 had and some don't. Id like to make it so I don't have to replace my whole power steering unit.

I only have one pic of my old set up and since its dark youll have to wait for some more pictures of the current set up. I have it so the p/s works buts its super sketchy, the jeep isn't on the road right now so I don't need a story about my safety I just start it daily but it will be back on the road in about a week.

Edit: I know you cant see much in the picture, Ill have to find other peoples set up that originally looked like mine.

Attached Thumbnails
Click image for larger version

Name:	Clean2.jpg
Views:	59
Size:	237.9 KB
ID:	716385  
__________________
Red 92 YJ 2.5l, 31x10.5x15 Goodyear Authorities
WellsR is offline   Quote
Old 01-30-2014, 02:32 PM
Thread Starter
  #2
Jeeper
 
WellsR's Avatar
 
Join Date: Aug 2010
Location: New York
Posts: 625
Bump...

Pictures in a little bit

__________________
Red 92 YJ 2.5l, 31x10.5x15 Goodyear Authorities
WellsR is offline   Quote
Old 01-30-2014, 02:46 PM
Thread Starter
  #3
Jeeper
 
WellsR's Avatar
 
Join Date: Aug 2010
Location: New York
Posts: 625
What I'm looking at now
Attached Thumbnails
Click image for larger version

Name:	ForumRunner_20140130_154550.jpg
Views:	47
Size:	71.6 KB
ID:	718745   Click image for larger version

Name:	ForumRunner_20140130_154558.jpg
Views:	51
Size:	76.8 KB
ID:	718753  

Click image for larger version

Name:	ForumRunner_20140130_154613.jpg
Views:	54
Size:	78.5 KB
ID:	718761  
__________________
Red 92 YJ 2.5l, 31x10.5x15 Goodyear Authorities
WellsR is offline   Quote
Sponsored Links
Advertisement
 
Old 01-30-2014, 03:18 PM   #4
Jeeper
 
Mowrangler's Avatar
 
Join Date: Jun 2013
Location: Tampa Fl.
Posts: 1,727
My guess is that you should have swapped intake manifolds and all brackets to the new long block.I make a habit that if the motor doesnt come out of the exact year make and model i am putting in into I swap EVERYTHING, sensors brackets manifolds ,everything.
__________________
95 YJ 2.5 5 speed 33" Mud Rovers SOA
A frustrating WORK IN PROGRESS
Mowrangler is offline   Quote
Old 01-30-2014, 03:39 PM
Thread Starter
  #5
Jeeper
 
WellsR's Avatar
 
Join Date: Aug 2010
Location: New York
Posts: 625
Quote:
Originally Posted by Mowrangler View Post
My guess is that you should have swapped intake manifolds and all brackets to the new long block.I make a habit that if the motor doesnt come out of the exact year make and model i am putting in into I swap EVERYTHING, sensors brackets manifolds ,everything.
I thought about that but all of my original gear was mostly shot cause I abused it horribly as why it threw a rod lol(learned my lesson). But the Intake manifold was cracked so it wasn't even a thought to change it. The old brackets didn't line up either I played with them for hours.

Its seems what I'm looking at is mostly a new p/s set up. If I'm going to look at that though I still need input on what year I'm looking for. Is it for a yj or a tj?

I've also been thinking about making a simple bracket but the pully still doesn't line up right so that doesn't really fix my problem.
__________________
Red 92 YJ 2.5l, 31x10.5x15 Goodyear Authorities
WellsR is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 12:56 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.