Speedo not working - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum

Join Wrangler Forum Today


Like Tree1Likes
  • 1 Post By IRQ
Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-11-2019, 08:13 PM
Thread Starter
  #1
Newb
 
Join Date: Jul 2018
Location: Homestead, Florida
Posts: 8
Speedo not working

I have a 1995 yj with a 4.0, 5 speed
The tack wasn’t working, so I replace the the gauges with a used one. The tack is working however the speedometer isn’t. So I have replace the speed sensor on the transfer case from rock auto.
So I tested the voltage and the white/ orange wire has 4.9 volts and the orange wire has 7.4. So I’m at a loss not sure what to do next? Thanks Joey

Jmoesch is offline   Quote
Old 05-11-2019, 11:05 PM   #2
IRQ
Jeeper
 
IRQ's Avatar
 
Join Date: Dec 2014
Location: NY
Posts: 2,039
Click the ✘, find the FSM, turn to page 380
Got it at last likes this.

__________________
1995 Rio Grande 2.5L AX-5 50,000 miles Stock
IRQ is offline   Quote
Old 05-12-2019, 10:51 AM   #3
Jeeper
 
UPStrades's Avatar
 
Join Date: Nov 2017
Location: El Paso TX
Posts: 378
Mine was not working as well. Replace my vss and nothing. Then I learned how to clock the tcase. Since you replaced your tcase, double check that you're clocked correctly.
UPStrades is offline   Quote
Sponsored Links
Advertisement
 
Old 05-16-2019, 10:47 PM   #4
Jeeper
 
Wowreefer's Avatar
 
Join Date: Dec 2018
Location: Carlsle, Pa
Posts: 38
I replaced my transfer case sensor with a cheap hall effect sensor from mouser works fine. I think it was less than 20 dollars of i remember correctly. Finding the receipt could be chore.
Wowreefer is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedo not working, Where do I start? Frenz YJ Tech Forum 3 02-01-2012 03:21 PM
Speedo not working and dies randomly TJe0454 TJ General Discussion Forum 9 12-12-2011 08:19 AM
Can't figure out why speedo not working but Tach is. DanS YJ Tech Forum 2 09-10-2011 07:09 PM
1997 4 cyl speedo and odometer not working wcope004 TJ General Discussion Forum 1 08-14-2011 01:00 PM
Speedo not working.. George T. YJ Tech Forum 5 06-06-2009 07:07 AM





All times are GMT -5. The time now is 03:56 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC