2014 Alpine system replacement - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics

Join Wrangler Forum Today


Like Tree1Likes
  • 1 Post By jaysong
Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-30-2019, 03:44 PM
Thread Starter
  #1
Newb
 
Bubbz.JKU's Avatar
 
Join Date: Jun 2019
Location: Colorado
Posts: 4
2014 Alpine system replacement

Hey everyone. I've been searching for days(and hopefully don't just suck at searching) and can't really find definitive answers to some questions I have about replacing the stock system.

I just got this Jeep a week ago, and already hate the stock stereo system. The headunit is the 430 and it has the factory sub(which doesn't seem to work at all).

I've already purchased a new headunit, the Kenwood DMX906S(for that wireless carplay goodness), and Maestro RR unit along with Metra kit and antenna adapter. I haven't received it yet, so I don't know how I'll like the sound with the stock speakers. I'm thinking that I just want to replace it all and do a component set up front and some coaxials in the sound bar amplified off a 4 channel amp, and maybe do a Rockford P300 sub in the back.

My questions really come down to the stock amp, and if it needs to be in the Jeep still. Will anything not work correctly between the new stereo through the Maestro? Would it be best to run all new speaker wire? I'm seeing that the amplified systems don't have all 8 speaker wires behind the headunit, can I easily grab them after the factory amp and run speedwire? I want to do the install myself, as I've done with most all of my previous cars. I just don't want to mess anything up, or have something weird come up dealing with the factory amp.

Thanks for any and all input!

-Kaleb

Bubbz.JKU is offline   Quote
Old 06-30-2019, 08:19 PM   #2
Supporting Member

5-Year WF Supporting Member
 
jaysong's Avatar
 
Join Date: May 2016
Location: Prior Lake
Posts: 1,039
Here is what I did with my 2014.

jaysong is offline   Quote
Old 06-30-2019, 09:51 PM
Thread Starter
  #3
Newb
 
Bubbz.JKU's Avatar
 
Join Date: Jun 2019
Location: Colorado
Posts: 4
Quote:
Originally Posted by jaysong View Post
Here is what I did with my 2014.
Thanks for the link! Somehow in my searching I hadn't seen your post. I take it nothing was lost or doesn't work correctly with the factory amp removed? That's what I was hoping to hear! Oh and btw, some of your pictures aren't working.
Bubbz.JKU is offline   Quote
Sponsored Links
Advertisement
 
Old 06-30-2019, 10:13 PM   #4
Supporting Member

5-Year WF Supporting Member
 
jaysong's Avatar
 
Join Date: May 2016
Location: Prior Lake
Posts: 1,039
Quote:
Originally Posted by Bubbz.JKU View Post
Thanks for the link! Somehow in my searching I hadn't seen your post. I take it nothing was lost or doesn't work correctly with the factory amp removed? That's what I was hoping to hear! Oh and btw, some of your pictures aren't working.
Here are some photos.
Bubbz.JKU likes this.
jaysong is offline   Quote
Old 07-01-2019, 06:34 PM   #5
Jeeper
 
terpsmandan's Avatar
 
Join Date: Dec 2009
Location: Penn Yan, NY
Posts: 1,867
Look up the tweeter mod, speaker mod and subwoofer mod in the JK section. I did all three on my 09 with the stock Infinity, added a Pioneer HU (AVH-X2700BS first and just replaced it with a MVH2300NEX (wanted carplay)) and IMO it sounds great and I am very picky when it comes to sound.
terpsmandan is online now   Quote
Old 07-12-2019, 11:46 PM   #6
Jeeper
 
Join Date: Jan 2014
Location: West Texas
Posts: 90
Tweeter mod was a huge improvement. I wished I had made a recording of before and after.

https://www.wranglerforum.com/f274/s...ap-662985.html

https://www.wranglerforum.com/f274/s...nt-921921.html

Sarkaukar2000 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 11:31 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC