Brake Light, ABS Issues after aftermarket speakers and amplifiers installed -2014 JKU - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-21-2016, 10:00 AM
Thread Starter
  #1
Jeeper
 
TheGorilla's Avatar
 
Join Date: Apr 2016
Posts: 27
Brake Light, ABS Issues after aftermarket speakers and amplifiers installed -2014 JKU

Just a heads up...
I recently had a subwoofer/amp installed along with all the EOM speakers replaced and an additional amplifier installed to power them as well (while keeping the factory head unit - in my 2014 JKU

I picked up my Jeep from the installer and while driving away I noticed my brakes felt "funky", then I noticed my brake dash light was on, then I noticed a whiney/dull motor/fan type sound (with the stereo powered off).

I spent the better part of the day yesterday combing the web trying to find what the potential problem/resolution might be...

I found a plethora of potential problems - CAN-BUS corruption, brake light switch issues, grounding issues and more.

Here's what it was...
During the install, the younger shop newbie while drilling a hole through the firewall to run wire, came up a little high and put a hole on the bottom-backside of the brake booster.

Thankfully, they found it pretty quickly, they're paying to have it replaced etc. I just wanted to post this little FYI up on here in the event that someone someday runs into a similar issue.

I just bought my first Jeep 2 weeks ago, joined this forum soon after and have found it to be a great resource.

TheGorilla is offline   Quote
Old 04-24-2016, 08:01 PM   #2
Supporting Member

5-Year WF Supporting Member
 
ProgRockPaul's Avatar
 
Join Date: Mar 2016
Location: Riverside, CA
Posts: 644
Wow ... of all the things to run the drill into ... the brake booster!
ProgRockPaul is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 02:27 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.