CB antenna SWR reading of 2.5, help plz - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics

Join Wrangler Forum Today


Like Tree1Likes
  • 1 Post By realshelby
Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-11-2018, 08:35 PM
Thread Starter
  #1
Jeeper
 
dragonfish's Avatar
 
Join Date: Feb 2016
Location: California
Posts: 87
CB antenna SWR reading of 2.5, help plz

CB newb here. I installed a 3' Firestik antenna using a spare tire carrier antenna mount on my JKU (hardtop). I am getting SWR readings of about 2.5 on channels 1 and 40 and just over 2 on channel 20. I know those numbers are not good, but they are not in the red either.

Several questions:

What SWR readings are people getting with this kind of setup?

Could I have a RF grounding issue? Or would that cause the numbers to go over 3?

I got the bracket from a friend who was no longer using it. It had a little bit of rust where the powdercoating had been scraped off. I scraped at it, but not all of it came off. Would that little bit of rust be enough to affect grounding?

What other non-drastic (let's try these first) measures can I try to lower the SWR?

Thanks.

dragonfish is offline   Quote
Old 03-11-2018, 08:58 PM   #2
Jeeper
 
OlYellerTJ's Avatar
 
Join Date: Nov 2010
Location: East of the CT River
Posts: 802
Rust is not conductive, sand or wire wheel to reach bare metal. Also, check to see that the antenna is properly connected to the mount. Jerry Bransford has posted a diagram of the proper set up for the antenna/mount connection: https://www.wranglerforum.com/attachm...1&d=1470853054

__________________
This message is composed of recycled electrons. None of these electrons has been harmed or injured in the creation and transmission of this message but they have been shamelessly exploited for this use.

Ol' Yeller TJ
OlYellerTJ is offline   Quote
Old 03-12-2018, 07:15 AM   #3
Jeeper
 
Join Date: Oct 2017
Location: Houston, Texas
Posts: 348
Is the mounted attached to the plastic tire carrier? There is no way to get that grounded without running a ground strap.

Over 2:1 SWR means something isn't right. Won't hurt the radio, but it won't transmit or possibly even receive as well as it should.

If the mount is grounded, try tuning the tip of the antenna. I assume you have one of the adjustable tip models? You should notice a change in SWR reading as you lengthen or shorten the tip. If the range of the adjustment runs out, that will tell you the antenna is too short or too long. If running a spring at the bottom, you can remove it. If you need to add length you can use a piece of steel threaded on both ends and a couple to reattach the antenna.

If nothing you do seems to change the SWR, there are problems with the coax or mount most likely.
OlYellerTJ likes this.
__________________
2017 JKU RECON silver
realshelby is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 11:32 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC