instrument panel, headlights and wipers don't work - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-25-2009, 01:38 AM
Thread Starter
  #1
Newb
 
Join Date: Oct 2009
Posts: 3
instrument panel, headlights and wipers don't work

I started my Jeep today and found that my instruments don't work and both my windshield wiper and headlight switches also do nothing. Oddly my headlights now come on as soon as I start the Jeep up but I can't turn them off...

It was almost dark when I found all this out so haven't had a chance to look at the fuses yet but going by the users manual no single fuse would account for this combination of problems.

Has this ever happened to any of you guys, or does anyone have any insight or ideas of where to start looking?

haynick is offline   Quote
Old 10-25-2009, 06:23 AM   #2
Jeeper
 
bmanrkg3's Avatar
 
Join Date: May 2006
Location: 20 minutes from everywhere in cape may county,NJ
Posts: 490
Send a message via AIM to bmanrkg3 Send a message via Yahoo to bmanrkg3
Gremlins...

__________________
I am the anti chrome.
bmanrkg3 is offline   Quote
Old 10-25-2009, 07:30 AM   #3
Jeeper
 
Seawalker's Avatar
 
Join Date: Sep 2009
Location: Western , NC
Posts: 300
Check the relay under the hood.
Seawalker is offline   Quote
Sponsored Links
Advertisement
 
Old 10-25-2009, 03:00 PM
Thread Starter
  #4
Newb
 
Join Date: Oct 2009
Posts: 3
Can you point me to where the relay is exactly? it's an 07 wrangler by the way.
haynick is offline   Quote
Old 10-26-2009, 10:01 PM
Thread Starter
  #5
Newb
 
Join Date: Oct 2009
Posts: 3
Well after a trip to the dealer, come to find out that it was just a bit of corrosion on the connection for the instrument panel.
haynick is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 07:59 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.