Pioneer 2330NEX Dead - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-11-2020, 03:15 PM
Thread Starter
  #1
Jeeper
 
Join Date: Feb 2018
Posts: 190
Pioneer 2330NEX Dead

Tried everything I could find so turning to you all at this point.

Went to the gym this morning, no issues, radio ran fine (note it was raining out, but I have 0 leaks or anything of the like in the JKU).

Turned it on to leave and all was dead, no lights or anything, so when I go home I opened up the dash. At this point here is what I have going on.
- Maestro is blinking 2 red lights (communication error). I've reflashed it twice to no avail, reset it... Seems to be working but I'm not ruling that out 100%
- Tried jiggling the key, disconnecting the battery (for long periods of time) nothing, same, just one dead radio and a blinking maestro
- Plugged in the old stereo (OEM) lights came on for the clock (no way to play anything but it seemed to be working (better than my Pioneer at this point)
- I've checked the wiring and nothing looks fried damaged, etc. All seems to be connected the same (I soldered and put heat shrink on everything so I'm confident nothing jiggled apart, especially from sitting in the parking lot)
- Checked the fuses, unplugged, replugged all looked good.

Outside of a randomly dead stereo, anything I'm missing here?

Thanks everyone!

bdog22 is offline   Quote
Old 02-12-2020, 05:49 PM   #2
Jeeper
 
Join Date: Apr 2013
Posts: 13,235
Try running plus 12 to accessory red wire on aftermarket radio (while ground and battery yellow wire also connected)if that turns it on issue is the silly can bus adapter


Sent from my iPhone using Tapatalk

Digger84 is online now   Quote
Old 02-14-2020, 10:34 AM   #3
WF approved Offical Jeep Account.
 
JeepCares's Avatar
 
Join Date: Jul 2011
Location: Mopar World Headquarters, Center Line, MI
Posts: 1,353
Quote:
Originally Posted by bdog22 View Post
Tried everything I could find so turning to you all at this point.

Went to the gym this morning, no issues, radio ran fine (note it was raining out, but I have 0 leaks or anything of the like in the JKU).

Turned it on to leave and all was dead, no lights or anything, so when I go home I opened up the dash. At this point here is what I have going on.
- Maestro is blinking 2 red lights (communication error). I've reflashed it twice to no avail, reset it... Seems to be working but I'm not ruling that out 100%
- Tried jiggling the key, disconnecting the battery (for long periods of time) nothing, same, just one dead radio and a blinking maestro
- Plugged in the old stereo (OEM) lights came on for the clock (no way to play anything but it seemed to be working (better than my Pioneer at this point)
- I've checked the wiring and nothing looks fried damaged, etc. All seems to be connected the same (I soldered and put heat shrink on everything so I'm confident nothing jiggled apart, especially from sitting in the parking lot)
- Checked the fuses, unplugged, replugged all looked good.

Outside of a randomly dead stereo, anything I'm missing here?

Thanks everyone!

Hi bdog22,
I can see why this might be a frustrating situation for you and your Wrangler. Have you had a chance to address this with your dealer yet? If you plan on making an appointment to diagnose your vehicle, feel free to send us a PM for additional assistance.

Kathryn
JeepCares
JeepCares is online now   Quote
Sponsored Links
Advertisement
 
Old 02-15-2020, 05:54 AM
Thread Starter
  #4
Jeeper
 
Join Date: Feb 2018
Posts: 190
Thank you for the offer. No need bring this to the dealer since it is aftermarket stuff. I ended up buying a new head unit, plugged it all in and that is working. Definitely a dead Pioneer head unit.

Quote:
Originally Posted by JeepCares View Post
Hi bdog22,
I can see why this might be a frustrating situation for you and your Wrangler. Have you had a chance to address this with your dealer yet? If you plan on making an appointment to diagnose your vehicle, feel free to send us a PM for additional assistance.

Kathryn
JeepCares
bdog22 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 07:42 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.