Replacement subwoofer in '04 Jeep TJ X not working - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-07-2019, 04:13 PM
Thread Starter
  #1
Newb
 
Join Date: Oct 2018
Posts: 11
Replacement subwoofer in '04 Jeep TJ X not working

Hello All,

I have a '04 TJ X that I am attempting to replace the subwoofer in. Replacement is Pyramid WX65X and I have a JVC KD-SR40 head unit.
I have gotten the old sub out and the new one in however it will not play anything or make any noise.
I checked the fuse it's fine, I used a multimeter to check to see if the amp is getting power it is (12V). I also checked to see if the leads to the sub got power there are two sets of two wires that go to the sub (a red and black, brown and gray) only the red and black are giving power(1.88V).

I don't have any experience in car audio so any help is very much appreciated. Please don't hesitate to ask for more details.

Thanks in advance.

__________________
Flame Red '04 Jeep TJ X
107K Miles
First Car
MasonD is offline   Quote
Old 04-08-2019, 08:27 AM   #2
Supporting Member

5-Year WF Supporting Member
 
Join Date: Jan 2017
Location: Iowa
Posts: 529
The Pyramid WX65X appears to be a midwoofer/midrange, not a subwoofer. Where in the Jeep did you install these? (Dash, soundbar, somewhere in rear...) Are you running a separate pair of tweeters with these?



Did what you had in it's place play before you installed the new speakers?


Tell me more about what components are in the system. Which amp, what crossover settings (if any) you have set on the amp, etc.

__________________
2017 Firecracker Red JK Sport
2018 Hella Yella JLU Sport
crazychile is offline   Quote
Old 04-08-2019, 12:10 PM
Thread Starter
  #3
Newb
 
Join Date: Oct 2018
Posts: 11
Quote:
Originally Posted by crazychile View Post
The Pyramid WX65X appears to be a midwoofer/midrange, not a subwoofer. Where in the Jeep did you install these? (Dash, soundbar, somewhere in rear...) Are you running a separate pair of tweeters with these?



Did what you had in it's place play before you installed the new speakers?


Tell me more about what components are in the system. Which amp, what crossover settings (if any) you have set on the amp, etc.
I am using it to replace the stock sub in the center console. I am still using the stock amp and wiring.

The stock sub did not work so I looked at the forum post that state that they changed there stock sub with the pyramid.
__________________
Flame Red '04 Jeep TJ X
107K Miles
First Car
MasonD is offline   Quote
Sponsored Links
Advertisement
 
Old 04-09-2019, 07:37 AM   #4
Supporting Member

5-Year WF Supporting Member
 
Join Date: Jan 2017
Location: Iowa
Posts: 529
How are you connecting the aftermarket JVC deck to the stock amp? Is the stock amp designed to power all your speakers or just the sub? I'm afraid I'm not a TJ stock stereo expert to know how it was originally configured from the factory



From what you've described so far, I'm inclined to think that the problem is probably between the deck and the amp. Then the other step would be to do a proper bench test of the amp, but that gets more tech nerdy and complicated.


Also, are your full range speakers connected directly to your deck and do they work fine?
__________________
2017 Firecracker Red JK Sport
2018 Hella Yella JLU Sport
crazychile is offline   Quote
Reply

Tags
audio issues , audio questions , sub woofer , subwoofer , subwoofer replacement

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Subwoofer Not Working After CD Player Installed 02WranglerTJ General Jeep Discussion 19 07-25-2019 09:58 PM
Replacementt subwoofer in '04 Jeep TJ X not working MasonD TJ Tech Forum 12 04-07-2019 07:47 PM
04 TJ question rear wiper not working fey1231 TJ Tech Forum 0 05-25-2015 08:47 PM
Stock console subwoofer not working Robiscool11 TJ Tech Forum 23 01-22-2014 05:58 PM
04' Stock Subwoofer Not Working Weasy TJ General Discussion Forum 5 11-14-2012 07:23 PM





All times are GMT -5. The time now is 11:46 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC