What could be the issue with stereo. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-05-2018, 10:46 AM
Thread Starter
  #1
Newb
 
Join Date: May 2018
Posts: 2
What could be the issue with stereo.

I installed a cheap pioneer head unit in my wife's 2000 Jeep Wrangler. The old Pioneer unit that was in it did not work. After the installation all four speakers sounded like they were blown so I bought some new JBL speakers and I'm having the same issue. What could possibly be the issue?
Thanks!!

HowWeRoll is offline   Quote
Old 06-05-2018, 02:10 PM   #2
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 48,212
What exactly is the sound problem that you're describing as sounding like the speakers are blown?

__________________
When you have a choice, buy American.
Jerry Bransford is offline   Quote
Old 06-05-2018, 02:24 PM
Thread Starter
  #3
Newb
 
Join Date: May 2018
Posts: 2
There's not much volume there and once it reaches about half way there is a lot of crackling with the tempo of the song.
HowWeRoll is offline   Quote
Sponsored Links
Advertisement
 
Old 06-06-2018, 10:16 AM   #4
Supporting Member

5-Year WF Supporting Member
 
Join Date: Jan 2017
Location: Iowa
Posts: 529
Did you use an install kit wiring harness or just wire direct into the old wiring. Maybe you have something jumbled up by mistake.


Also make sure you have all youre tone controls set flat, no bass boost, etc.



If you can, pull the deck and bench test it. A cheap 12v power supply is great for this. Then just connect 2 old car speakers to the radio and see if you have the same problem. It's unlikely that the amp is bad in the new deck, but it is possible.
crazychile is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 07:33 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC